summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2017-09-29 12:49:47 +0200
committerAlexander F Rødseth2017-09-29 12:49:47 +0200
commit78b6e06c31ecd26715228162a39077eca2e50a47 (patch)
tree3f3935838f23d9cecdeb7d78f2e63159a2b6d6ab
downloadaur-78b6e06c31ecd26715228162a39077eca2e50a47.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e85d065df7ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Fri Sep 29 10:49:40 UTC 2017
+pkgbase = pamcan
+ pkgdesc = Output an image of a Pam can on the console
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/xyproto/pamcan/
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ source = https://github.com/xyproto/pamcan/releases/download/0.1/pamcan-0.1.tar.gz
+ sha256sums = 150934000c6f407f746b5a10fc4d0cdc987a3f85d86528b03321f272643ea7c3
+
+pkgname = pamcan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49bbdd9f374b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+
+pkgname=pamcan
+pkgver=0.1
+pkgrel=1
+pkgdesc='Output an image of a Pam can on the console'
+arch=('x86_64')
+url='https://github.com/xyproto/pamcan/'
+license=('MIT')
+makedepends=('go')
+source=("https://github.com/xyproto/pamcan/releases/download/0.1/pamcan-0.1.tar.gz")
+sha256sums=('150934000c6f407f746b5a10fc4d0cdc987a3f85d86528b03321f272643ea7c3')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ go build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:ts=2 sw=2 et: