summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2015-06-08 13:22:10 +0300
committerMantas Mikulėnas2015-06-08 13:22:10 +0300
commit3e2e004d1f5918e51fec74b28d8cc2183c2967fd (patch)
tree6b75e6e60976b5d1b6c18b124ee91a842bc0aea4
downloadaur-3e2e004d1f5918e51fec74b28d8cc2183c2967fd.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01db69306840
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pamtester
+ pkgdesc = Tiny program to test the pluggable authentication modules (PAM) facility
+ pkgver = 0.1.2
+ pkgrel = 3
+ url = http://pamtester.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = pam
+ source = http://sourceforge.net/projects/pamtester/files/pamtester/0.1.2/pamtester-0.1.2.tar.gz
+ sha256sums = 83633d0e8a4f35810456d9d52261c8ae0beb9148276847cae8963505240fb2d5
+
+pkgname = pamtester
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7616c0426a22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mantas Mikulėnas <grawity@gmail.com>
+pkgname=pamtester
+pkgver=0.1.2
+pkgrel=3
+pkgdesc="Tiny program to test the pluggable authentication modules (PAM) facility"
+arch=(i686 x86_64)
+url="http://pamtester.sourceforge.net/"
+license=(custom)
+depends=(pam)
+source=("http://sourceforge.net/projects/pamtester/files/pamtester/$pkgver/pamtester-$pkgver.tar.gz")
+sha256sums=('83633d0e8a4f35810456d9d52261c8ae0beb9148276847cae8963505240fb2d5')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname"
+}
+
+# vim: ts=2:sw=2:et