summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgeekmar2020-08-28 13:10:05 +0000
committergeekmar2020-08-28 13:10:05 +0000
commitbc8f284b0904afb04a5d8f70b2f578258f26fe7a (patch)
tree28cf01431939adcc3a4417dcbe1fb9bafe87aa31
downloadaur-bc8f284b0904afb04a5d8f70b2f578258f26fe7a.tar.gz
init
-rw-r--r--.SRCINFO20
-rwxr-xr-xPKGBUILD24
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d1313b46d42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = panda-files-git
+ pkgdesc = file manager for PandaOS
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://github.com/pandaos/panda-files
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = kwindowsystem
+ depends = qt5-x11extras
+ depends = qt5-svg
+ depends = libexif
+ depends = menu-cache
+ depends = qt5-base
+ source = panda-files-git-b3b039fa20efb59a19c4508dfe4eeca4ec488796.tar.gz::https://github.com/pandaos/panda-files/archive/b3b039fa20efb59a19c4508dfe4eeca4ec488796.tar.gz
+ sha512sums = afaa0eeaaf6033d8c77c84160d71c9325de5d90db8476d4db68a7eee1ab5dd487ea617d21406ddb1376886eee0f48f8b55adadd4ec97a0af267edb8c3bf9fa3b
+
+pkgname = panda-files-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..0f8adeb04f6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer:geekmar(xzh2002436@gmail.com)
+pkgname=panda-files-git
+pkgver=1.1
+_commit=b3b039fa20efb59a19c4508dfe4eeca4ec488796
+pkgrel=1
+pkgdesc="file manager for PandaOS"
+arch=(x86_64)
+url="https://github.com/pandaos/panda-files"
+license=('GPL3')
+depends=('kwindowsystem' 'qt5-x11extras' 'qt5-svg' 'libexif' 'menu-cache' 'qt5-base')
+makedepends=('cmake' 'qt5-tools')
+source=("$pkgname-$_commit.tar.gz::https://github.com/pandaos/panda-files/archive/$_commit.tar.gz")
+sha512sums=('afaa0eeaaf6033d8c77c84160d71c9325de5d90db8476d4db68a7eee1ab5dd487ea617d21406ddb1376886eee0f48f8b55adadd4ec97a0af267edb8c3bf9fa3b')
+
+build() {
+ cd panda-files-$_commit
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+ cd panda-files-$_commit
+ make DESTDIR="$pkgdir" install
+}