summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcroxis2015-06-17 12:36:45 -0700
committercroxis2015-06-17 12:36:45 -0700
commit22cea61077c20604537710eda07795e14ff88d59 (patch)
treee16a691861a943bf396806b1c5682e4e54455b1e
downloadaur-22cea61077c20604537710eda07795e14ff88d59.tar.gz
Initial import
-rw-r--r--.SRCINFO52
-rw-r--r--PKGBUILD102
2 files changed, 154 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..397c282bd862
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,52 @@
+pkgbase = panda3d-git
+ pkgdesc = A 3D game engine with Python bindings. SDK package. Git Version. Optional dependencies you want to support need to be installed before panda3d.
+ pkgver = git-HEAD
+ pkgrel = 2
+ url = http://www.panda3d.org
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = bison
+ makedepends = cmake
+ makedepends = git
+ depends = desktop-file-utils
+ depends = shared-mime-info
+ depends = python2
+ optdepends = xorg-server: X11 support
+ optdepends = libgl: OpenGL support for X11
+ optdepends = python: Experimental Python3 bindings
+ optdepends = openssl: Provides some networking and encryption support
+ optdepends = libjpeg: Required to read and write jpeg images
+ optdepends = libpng: Required to read and write png images
+ optdepends = freetype2: Required to use dynamic fonts (such as TTF fonts)
+ optdepends = gtk2: PStats analysis and debugging tool
+ optdepends = libtiff: Required to read and write tiff images
+ optdepends = nvidia-cg-toolkit: shader support
+ optdepends = ode-compat: Support for the ODE physics engine
+ optdepends = openal: OpenAL audio
+ optdepends = zlib: Compression support
+ optdepends = libxxf86dga: Relative mouse mode
+ optdepends = artoolkit: library for augmented reality (AUR)
+ optdepends = assimp: Import various well-known 3D model formats in an uniform manner
+ optdepends = bullet: Support for the physics engine
+ optdepends = eigen: Optimised linear algebra library
+ optdepends = ffmpeg: Required to load and play video textures and play mp3s (broken)
+ optdepends = fmodex: FMod audio
+ optdepends = libxcursor: Custom cursor icons
+ optdepends = libxrandr: Resolution switching
+ optdepends = librocket: Librocket GUI support
+ optdepends = libsquish: DXT support (AUR)
+ optdepends = opencv: alternative to ffmpeg for video texture support
+ optdepends = fftw: Lossy animation compression in bam files (Does not work)
+ optdepends = fcollada: used for dae2egg and for loading dae files directly into Panda (unavailable)
+ optdepends = vrpn: support for virtual reality trackers (unavailable)
+ optdepends = libgles: OpenGL ES support
+ optdepends = libegl: GLX for OpenGL ES
+ provides = panda3d
+ conflicts = panda3d
+ source = panda3d::git+https://github.com/panda3d/panda3d.git
+ md5sums = SKIP
+ sha256sums = SKIP
+
+pkgname = panda3d-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68a4b0a169e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,102 @@
+# Maintainer: David Radford <croxis gmail com>
+# Contributor: Faule Socke <github@socker.lepus.uberspace.de>
+# Contributor: Robin Baumgartner <robin@baumgartners.ch>
+# Contributor: Hubert Grzeskowiak <arch at nemesis13 de>
+
+pkgname=panda3d-git
+pkgver=git-HEAD
+pkgrel=2
+pkgdesc="A 3D game engine with Python bindings. SDK package. Git Version. Optional dependencies you want to support need to be installed before panda3d."
+url="http://www.panda3d.org"
+arch=('i686' 'x86_64')
+license=('BSD')
+provides=('panda3d')
+conflicts=('panda3d')
+
+depends=('desktop-file-utils' 'shared-mime-info'
+ 'python2')
+makedepends=('bison' 'cmake' 'git')
+
+# NOTICE: please read http://www.panda3d.org/manual/index.php/Dependencies for
+# more information. Optdepends you want your package to support need to be
+# installed during compiletime! You don't need to change anything in the
+# pkgbuild to get support; makepanda automatically detects available
+# dependencies.
+optdepends=(# Pretty much required
+ 'xorg-server: X11 support'
+ 'libgl: OpenGL support for X11'
+ # Recommended
+ #'python2: Python2 bindings.'
+ 'python: Experimental Python3 bindings'
+ 'openssl: Provides some networking and encryption support'
+ 'libjpeg: Required to read and write jpeg images'
+ 'libpng: Required to read and write png images'
+ 'freetype2: Required to use dynamic fonts (such as TTF fonts)'
+ 'gtk2: PStats analysis and debugging tool'
+ 'libtiff: Required to read and write tiff images'
+ 'nvidia-cg-toolkit: shader support'
+ 'ode-compat: Support for the ODE physics engine'
+ 'openal: OpenAL audio'
+ 'zlib: Compression support'
+ 'libxxf86dga: Relative mouse mode'
+ # Optional
+ 'artoolkit: library for augmented reality (AUR)'
+ 'assimp: Import various well-known 3D model formats in an uniform manner'
+ 'bullet: Support for the physics engine'
+ 'eigen: Optimised linear algebra library'
+ 'ffmpeg: Required to load and play video textures and play mp3s (broken)'
+ 'fmodex: FMod audio'
+ 'libxcursor: Custom cursor icons'
+ 'libxrandr: Resolution switching'
+ 'librocket: Librocket GUI support'
+ 'libsquish: DXT support (AUR)'
+ 'opencv: alternative to ffmpeg for video texture support'
+ 'fftw: Lossy animation compression in bam files (Does not work)'
+ 'fcollada: used for dae2egg and for loading dae files directly into Panda (unavailable)'
+ 'vrpn: support for virtual reality trackers (unavailable)'
+ # ARM stuff, not really applicable, stated for completeness
+ # NOTE: if you have libgles, you _must_ install libegl for this package to compile
+ 'libgles: OpenGL ES support'
+ 'libegl: GLX for OpenGL ES'
+ )
+
+source=('panda3d::git+https://github.com/panda3d/panda3d.git')
+md5sums=('SKIP')
+sha256sums=('SKIP')
+
+JOBS=$(nproc)
+
+build() {
+ cd $srcdir/$pkgname
+ # disable broken extensions
+ # you can use PANDAFLAGS and BUILD_THREADS to control building
+ # building is very memory intensive so you might want to use less threads
+ python2 makepanda/makepanda.py --everything --no-opencv --no-maya2012 --no-fmodex --no-gles --no-gles2 --no-ffmpeg ${PANDAFLAGS} --threads ${BUILD_THREADS:-$JOBS}
+}
+
+package() {
+ cd $srcdir/$pkgname
+ python2 makepanda/installpanda.py --prefix=/usr --destdir="$pkgdir"
+ install -D -m644 "$srcdir/$pkgname/doc/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+post_install() {
+ ldconfig
+ update-mime-database usr/share/mime
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ update-mime-database usr/share/mime
+ update-desktop-database -q
+}
+
+post_remove() {
+ update-mime-database usr/share/mime
+ update-desktop-database -q
+}
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}