summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcroxis2019-01-18 18:44:30 -0800
committercroxis2019-01-18 18:44:30 -0800
commit72ac40d9a03d4720f90c95cfd4364d22539c793f (patch)
treea531d514f370adc38c5b036930ced3eb33289985
parentbae7daa7a807c41ec449994b4d6ba6a49197edd3 (diff)
downloadaur-72ac40d9a03d4720f90c95cfd4364d22539c793f.tar.gz
Updated dependencies
-rw-r--r--.SRCINFO8
-rwxr-xr-xPKGBUILD9
2 files changed, 12 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b842d8ce74..e01ed27fdf2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = panda3d-python2
pkgdesc = A 3D game engine with Python bindings. SDK package. Optional dependencies you want to support need to be installed before panda3d.
pkgver = 1.10.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.panda3d.org
install = panda3d.install
arch = i686
@@ -10,6 +10,7 @@ pkgbase = panda3d-python2
makedepends = python2
makedepends = bison
makedepends = cmake
+ makedepends = flex
depends = desktop-file-utils
depends = shared-mime-info
depends = xorg-server
@@ -40,6 +41,9 @@ pkgbase = panda3d-python2
optdepends = openal: OpenAL audio
optdepends = zlib: Compression support
optdepends = libxxf86dga: Relative mouse mode
+ optdepends = openexp: OpenEXR image format support
+ optdepends = assimp: Open Asset Import
+ optdepends = opus: Read .opus audio files
optdepends = bullet: Support for the physics engine
optdepends = eigen: Optimised linear algebra library
optdepends = fmodex: FMod audio
@@ -50,7 +54,7 @@ pkgbase = panda3d-python2
optdepends = artoolkit: library for augmented reality (AUR)
optdepends = opencv: alternative to ffmpeg for video texture support
optdepends = fcollada: used for dae2egg and for loading dae files directly into Panda (unavailable)
- optdepends = vrpn: support for virtual reality trackers (unavailable)
+ optdepends = vrpn-git: support for virtual reality trackers (unavailable)
optdepends = libgles: OpenGL ES support
optdepends = libegl: GLX for OpenGL ES
source = https://github.com/panda3d/panda3d/archive/v1.10.0.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index c0f456de404..c5bc70e5fc1 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=panda3d-python2
pkgver=1.10.0
-pkgrel=1
+pkgrel=2
pkgdesc="A 3D game engine with Python bindings. SDK package. Optional dependencies you want to support need to be installed before panda3d."
url="http://www.panda3d.org"
arch=('i686' 'x86_64')
@@ -12,7 +12,7 @@ license=('BSD')
depends=('desktop-file-utils' 'shared-mime-info' 'xorg-server' 'libgl'
'openssl' 'libjpeg' 'libpng' 'libtiff' 'freetype2' 'gtk2'
'openal' 'libxrandr' 'libxcursor' 'libxxf86dga')
-makedepends=('python2' 'bison' 'cmake')
+makedepends=('python2' 'bison' 'cmake' 'flex')
# NOTICE: please read http://www.panda3d.org/manual/index.php/Dependencies for
# more information. Optdepends you want your package to support, need to be
@@ -41,7 +41,10 @@ optdepends=(# Pretty much required
'openal: OpenAL audio'
'zlib: Compression support'
'libxxf86dga: Relative mouse mode'
+ 'openexp: OpenEXR image format support'
# Optional
+ 'assimp: Open Asset Import'
+ 'opus: Read .opus audio files'
'bullet: Support for the physics engine'
'eigen: Optimised linear algebra library'
'fmodex: FMod audio'
@@ -52,7 +55,7 @@ optdepends=(# Pretty much required
'artoolkit: library for augmented reality (AUR)'
'opencv: alternative to ffmpeg for video texture support'
'fcollada: used for dae2egg and for loading dae files directly into Panda (unavailable)'
- 'vrpn: support for virtual reality trackers (unavailable)'
+ 'vrpn-git: support for virtual reality trackers (unavailable)'
# ARM stuff, not really applicable, stated for completeness
# NOTE: if you have libgles, you _must_ install libegl for this package to compile
'libgles: OpenGL ES support'