summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcroxis2019-01-18 18:21:47 -0800
committercroxis2019-01-18 18:21:47 -0800
commitf2bd9a65969e75809842fefbcbc1c47054a16b3f (patch)
tree92472eda96df572230e84765e5ba8b9abee50f33
downloadaur-f2bd9a65969e75809842fefbcbc1c47054a16b3f.tar.gz
Update to 1.10.0
-rw-r--r--.SRCINFO62
-rwxr-xr-xPKGBUILD82
-rwxr-xr-xpanda3d.install17
3 files changed, 161 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..707d1487c877
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,62 @@
+pkgbase = panda3d
+ pkgdesc = A 3D game engine with Python bindings. SDK package. Optional dependencies you want to support need to be installed before panda3d.
+ pkgver = 1.10.0
+ pkgrel = 1
+ url = http://www.panda3d.org
+ install = panda3d.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = python2
+ makedepends = bison
+ makedepends = cmake
+ depends = desktop-file-utils
+ depends = shared-mime-info
+ depends = xorg-server
+ depends = libgl
+ depends = openssl
+ depends = libjpeg
+ depends = libpng
+ depends = libtiff
+ depends = freetype2
+ depends = gtk2
+ depends = openal
+ depends = libxrandr
+ depends = libxcursor
+ depends = libxxf86dga
+ optdepends = xorg-server: X11 support
+ optdepends = libgl: OpenGL support for X11
+ optdepends = python2: Python2 bindings
+ optdepends = python: Python 3 bindings
+ optdepends = openssl: Provides some networking and encryption support
+ optdepends = ffmpeg: Required to load and play video textures
+ optdepends = libjpeg: Required to read and write jpeg images
+ optdepends = libpng: Required to read and write png images
+ optdepends = freetype2: Required to use dynamic fonts (such as TTF fonts)
+ optdepends = gtk2: PStats analysis and debugging tool
+ optdepends = libtiff: Required to read and write tiff images
+ optdepends = nvidia-cg-toolkit: shader support
+ optdepends = ode-compat: Support for the ODE physics engine
+ optdepends = openal: OpenAL audio
+ optdepends = zlib: Compression support
+ optdepends = libxxf86dga: Relative mouse mode
+ optdepends = bullet: Support for the physics engine
+ optdepends = eigen: Optimised linear algebra library
+ optdepends = fmodex: FMod audio
+ optdepends = libxcursor: Custom cursor icons
+ optdepends = libxrandr: Resolution switching
+ optdepends = librocket: Librocket GUI support
+ optdepends = libsquish: DXT support (AUR)
+ optdepends = artoolkit: library for augmented reality (AUR)
+ optdepends = opencv: alternative to ffmpeg for video texture support
+ optdepends = fcollada: used for dae2egg and for loading dae files directly into Panda (unavailable)
+ optdepends = vrpn: support for virtual reality trackers (unavailable)
+ optdepends = libgles: OpenGL ES support
+ optdepends = libegl: GLX for OpenGL ES
+ source = https://github.com/panda3d/panda3d/archive/v1.10.0.tar.gz
+ source = panda3d.install
+ md5sums = 9eb28f8b98e909aed201014991255df8
+ md5sums = 057269173f3c1987953302519bc744fa
+
+pkgname = panda3d
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..784bbd71a4ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,82 @@
+# Maintainer: David Radford <croxis gmail com>
+# Contributor: Robin Baumgartner <robin@baumgartners.ch>
+# Contributor: Tucos <baspape@gmail.com>
+
+pkgname=panda3d
+pkgver=1.10.0
+pkgrel=1
+pkgdesc="A 3D game engine with Python bindings. SDK package. Optional dependencies you want to support need to be installed before panda3d."
+url="http://www.panda3d.org"
+arch=('i686' 'x86_64')
+license=('BSD')
+depends=('desktop-file-utils' 'shared-mime-info' 'xorg-server' 'libgl'
+ 'openssl' 'libjpeg' 'libpng' 'libtiff' 'freetype2' 'gtk2'
+ 'openal' 'libxrandr' 'libxcursor' 'libxxf86dga')
+makedepends=('python2' 'bison' 'cmake')
+
+# NOTICE: please read http://www.panda3d.org/manual/index.php/Dependencies for
+# more information. Optdepends you want your package to support, need to be
+# installed before compiletime! You don't need to change anything in the
+# pkgbuild to get support; makepanda automatically detects available
+# dependencies.
+
+# PYTHON NOTICE: Replace all instances of python2 with python to compile with
+# python 3 support instead
+
+optdepends=(# Pretty much required
+ 'xorg-server: X11 support'
+ 'libgl: OpenGL support for X11'
+ # Recommended
+ 'python2: Python2 bindings'
+ 'python: Python 3 bindings'
+ 'openssl: Provides some networking and encryption support'
+ 'ffmpeg: Required to load and play video textures'
+ 'libjpeg: Required to read and write jpeg images'
+ 'libpng: Required to read and write png images'
+ 'freetype2: Required to use dynamic fonts (such as TTF fonts)'
+ 'gtk2: PStats analysis and debugging tool'
+ 'libtiff: Required to read and write tiff images'
+ 'nvidia-cg-toolkit: shader support'
+ 'ode-compat: Support for the ODE physics engine'
+ 'openal: OpenAL audio'
+ 'zlib: Compression support'
+ 'libxxf86dga: Relative mouse mode'
+ # Optional
+ 'bullet: Support for the physics engine'
+ 'eigen: Optimised linear algebra library'
+ 'fmodex: FMod audio'
+ 'libxcursor: Custom cursor icons'
+ 'libxrandr: Resolution switching'
+ 'librocket: Librocket GUI support'
+ 'libsquish: DXT support (AUR)'
+ 'artoolkit: library for augmented reality (AUR)'
+ 'opencv: alternative to ffmpeg for video texture support'
+ 'fcollada: used for dae2egg and for loading dae files directly into Panda (unavailable)'
+ 'vrpn: support for virtual reality trackers (unavailable)'
+ # ARM stuff, not really applicable, stated for completeness
+ # NOTE: if you have libgles, you _must_ install libegl for this package to compile
+ 'libgles: OpenGL ES support'
+ 'libegl: GLX for OpenGL ES'
+ )
+
+install='panda3d.install'
+source=("https://github.com/panda3d/panda3d/archive/v$pkgver.tar.gz"
+ 'panda3d.install')
+
+JOBS=$(nproc)
+
+build() {
+ cd "$srcdir/panda3d-$pkgver"
+ #LD_LIBRARY_PATH=/usr/lib/openssl-1.0-compat/
+ # disable broken extensions
+ python2 makepanda/makepanda.py --everything --no-opencv --no-opencv --no-maya2012 --no-fmodex --no-gles --no-gles2 --no-openssl --no-egl ${PANDAFLAGS} --threads ${BUILD_THREADS:-$JOBS}
+}
+
+package() {
+ cd "$srcdir/panda3d-$pkgver"
+ python2 makepanda/installpanda.py --prefix=/usr --destdir="$pkgdir"
+ install -D -m644 "$srcdir/panda3d-$pkgver/doc/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+}
+md5sums=('9eb28f8b98e909aed201014991255df8'
+ '057269173f3c1987953302519bc744fa')
diff --git a/panda3d.install b/panda3d.install
new file mode 100755
index 000000000000..7707c271b9c7
--- /dev/null
+++ b/panda3d.install
@@ -0,0 +1,17 @@
+post_install() {
+ update-mime-database usr/share/mime
+ update-desktop-database -q
+ ldconfig
+}
+
+post_upgrade() {
+ update-mime-database usr/share/mime
+ update-desktop-database -q
+}
+
+post_remove() {
+ update-mime-database usr/share/mime
+ update-desktop-database -q
+}
+
+# vim:set ts=2 sw=2 et: