summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorofftkp2023-08-22 14:27:10 +0300
committerofftkp2023-08-22 14:28:47 +0300
commit4f7f6b81f73024d67e842d50c04666dd0f8173fb (patch)
tree39759f37c44615cc2db675e8e3670206b7256ded
downloadaur-4f7f6b81f73024d67e842d50c04666dd0f8173fb.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD51
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c0c57c3fa5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = panda3ds-git
+ pkgdesc = HLE 3DS emulator
+ pkgver = 0.4.r1203.d220d18
+ pkgrel = 1
+ url = https://github.com/wheremyfoodat/Panda3DS
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = ninja
+ makedepends = git
+ makedepends = clang
+ depends = gcc-libs
+ depends = libxext
+ provides = panda3ds
+ conflicts = panda3ds
+ source = git+https://github.com/wheremyfoodat/Panda3DS
+ sha256sums = SKIP
+
+pkgname = panda3ds-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a5450779d14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Paris Oplopoios <parisoplop@gmail.com>
+
+_pkgname=Panda3DS
+_latest_release=0.4
+_executable_name=Alber
+
+pkgname=panda3ds-git
+pkgver=0.4.r1203.d220d18
+pkgrel=1
+pkgdesc="HLE 3DS emulator"
+arch=('x86_64')
+# TODO: Update when there's an actual website
+url="https://github.com/wheremyfoodat/Panda3DS"
+license=('GPL3')
+depends=(
+ gcc-libs
+ libxext
+)
+makedepends=(
+ cmake
+ ninja
+ git
+ clang
+)
+provides=(panda3ds)
+conflicts=(panda3ds)
+source=("git+https://github.com/wheremyfoodat/Panda3DS")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "%s.r%s.%s" \
+ "$_latest_release" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+
+build() {
+ export CXX=clang++
+ export CC=clang
+ cd $_pkgname
+ git submodule update --init --recursive
+ cmake -S . -B build -Wno-dev -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DENABLE_USER_BUILD=ON -DENABLE_VULKAN=OFF -GNinja
+ cmake --build build -j$(nproc)
+}
+
+package() {
+ cd $_pkgname
+ install -vDm 755 "build/$_executable_name" "$pkgdir/usr/bin/$_pkgname"
+}