summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhalosghost2017-03-22 22:24:52 -0500
committerhalosghost2017-03-22 22:24:52 -0500
commit21f709a1207fbe283a6fd8bedcf3c9bb3e0821a4 (patch)
tree3572a51edf108f70005aa26622341e5218790084
downloadaur-21f709a1207fbe283a6fd8bedcf3c9bb3e0821a4.tar.gz
initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD39
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b77a177c0f29
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Thu Mar 23 03:23:19 UTC 2017
+pkgbase = pandabin-git
+ pkgdesc = A self-hostable, simple and fast pastebin written in C
+ pkgver = r85.996b17a
+ pkgrel = 1
+ url = https://github.com/HalosGhost/pandabin
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = tup
+ makedepends = clang
+ depends = lwan
+ depends = libutil-linux
+ depends = openssl
+ depends = sqlite3
+ provides = pandabin
+ conflicts = pandabin
+ source = git+https://github.com/HalosGhost/pandabin.git
+ sha256sums = SKIP
+
+pkgname = pandabin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5b2784888d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Sam Stuewe <halosghost at archlinux dot info>
+
+pkgname=pandabin-git
+pkgver=r85.996b17a
+pkgrel=1
+
+pkgdesc='A self-hostable, simple and fast pastebin written in C'
+url='https://github.com/HalosGhost/pandabin'
+arch=('i686' 'x86_64')
+license=('GPL2')
+
+provides=('pandabin')
+conflicts=('pandabin')
+
+depends=('lwan' 'libutil-linux' 'openssl' 'sqlite3')
+makedepends=('git' 'tup' 'clang')
+
+source=('git+https://github.com/HalosGhost/pandabin.git')
+sha256sums=('SKIP')
+
+pkgver () {
+ cd pandabin
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare () {
+ cd pandabin
+ ./configure --prefix='/usr'
+}
+
+build () {
+ cd pandabin
+ make
+}
+
+package () {
+ cd pandabin
+ make DESTDIR="${pkgdir}" install
+}