summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212024-07-04 19:23:33 +0200
committera8212024-07-04 19:23:33 +0200
commit01571d205176f00ab4dd996c10bb55c21ccf1cc3 (patch)
tree6864b484290701ddee2baa0dc4c341e7d1b06088
parent59912442021cc32736e47eb7a4ec4b2de57138de (diff)
downloadaur-01571d205176f00ab4dd996c10bb55c21ccf1cc3.tar.gz
Version 3.2.1
* Add optdepends from haskell-pandoc * Use SPDX identifier for license * Remove unneeded comments * Update description
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD38
2 files changed, 43 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 65431d1e56e6..323b30d73855 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,28 @@
pkgbase = pandoc-bin
- pkgdesc = Pandoc - executable only, without 750MB Haskell depends/makedepends
- pkgver = 3.1.13
+ pkgdesc = Conversion between documentation formats
+ pkgver = 3.2.1
pkgrel = 1
url = https://pandoc.org
arch = x86_64
arch = aarch64
- license = GPL2
- optdepends = texlive-core: for pdf output
- provides = pandoc=3.1.13
- provides = pandoc-cli=3.1.13
+ license = GPL-2.0-or-later
+ optdepends = pandoc-crossref: for numbering figures, equations, tables and cross-references to them with pandoc-crossref filter
+ optdepends = texlive-context: for pdf output using context engine
+ optdepends = groff: for pdf output using pdfroff engine
+ optdepends = python-weasyprint: for pdf output using weasyprint engine
+ optdepends = typst: for pdf output using typst engine
+ optdepends = tectonic: for pdf output using tectonic engine
+ optdepends = texlive-fontsrecommended: for pdf output using latex or xelatex engines
+ optdepends = texlive-latex: for pdf output using pdflatex engine
+ optdepends = texlive-xetex: for pdf output using xelatex engine
+ provides = pandoc=3.2.1
+ provides = pandoc-cli=3.2.1
conflicts = pandoc-cli
- source = pandoc-bin-source-3.1.13.tar.gz::https://github.com/jgm/pandoc/archive/3.1.13.tar.gz
- sha256sums = e00265e5aa56ecb214d12fd7781e87d77abf101dd8d02e15c4d648ad50a5ef80
- source_x86_64 = pandoc-bin-bin-3.1.13.tar.gz::https://github.com/jgm/pandoc/releases/download/3.1.13/pandoc-3.1.13-linux-amd64.tar.gz
- sha256sums_x86_64 = db556c98cf207d2fddc088d12d2e2f367d9401784d4a3e914b068fa895dcf3f0
- source_aarch64 = pandoc-bin-bin-3.1.13.tar.gz::https://github.com/jgm/pandoc/releases/download/3.1.13/pandoc-3.1.13-linux-arm64.tar.gz
- sha256sums_aarch64 = 678c09ac4227c88b491f6e75491e6da871fd08d79b8c0f0ee37b611f01ad3d25
+ source = pandoc-bin-3.2.1.tar.gz::https://github.com/jgm/pandoc/archive/3.2.1.tar.gz
+ sha256sums = c8b360a12b9b2b4be33215f212b444e6110aa7dcfbe49e84f08914855ad9b39a
+ source_x86_64 = https://github.com/jgm/pandoc/releases/download/3.2.1/pandoc-3.2.1-linux-amd64.tar.gz
+ sha256sums_x86_64 = 3568b0ab38aa8c7ddce0812fa9f7bea8aa43d1657c5e1e816ed92807719c0e2d
+ source_aarch64 = https://github.com/jgm/pandoc/releases/download/3.2.1/pandoc-3.2.1-linux-arm64.tar.gz
+ sha256sums_aarch64 = 23d30e7fcc113aabd85fc426d4b6f924f1b0eebb06c7efc36e9188d117ff58ec
pkgname = pandoc-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2b9e57a9040c..9fd79b22c405 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,40 @@
pkgname=pandoc-bin
-pkgver=3.1.13
+pkgver=3.2.1
pkgrel=1
-pkgdesc="Pandoc - executable only, without 750MB Haskell depends/makedepends"
+pkgdesc="Conversion between documentation formats"
url="https://pandoc.org"
-license=("GPL2")
+license=("GPL-2.0-or-later")
arch=('x86_64' 'aarch64')
conflicts=("pandoc-cli")
provides=("pandoc=$pkgver" "pandoc-cli=$pkgver")
-optdepends=('texlive-core: for pdf output')
+optdepends=(
+ 'pandoc-crossref: for numbering figures, equations, tables and cross-references to them with pandoc-crossref filter'
+ 'texlive-context: for pdf output using context engine'
+ 'groff: for pdf output using pdfroff engine'
+ 'python-weasyprint: for pdf output using weasyprint engine'
+ 'typst: for pdf output using typst engine'
+ 'tectonic: for pdf output using tectonic engine'
+ 'texlive-fontsrecommended: for pdf output using latex or xelatex engines'
+ 'texlive-latex: for pdf output using pdflatex engine'
+ 'texlive-xetex: for pdf output using xelatex engine'
+)
# The binary release doesn't have the datafiles, so we need to yoink those out of the source tarball, too.
-source=("$pkgname-source-$pkgver.tar.gz::https://github.com/jgm/pandoc/archive/${pkgver}.tar.gz")
-source_x86_64=("$pkgname-bin-$pkgver.tar.gz::https://github.com/jgm/pandoc/releases/download/${pkgver}/pandoc-${pkgver}-linux-amd64.tar.gz")
-source_aarch64=("$pkgname-bin-$pkgver.tar.gz::https://github.com/jgm/pandoc/releases/download/${pkgver}/pandoc-${pkgver}-linux-arm64.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/jgm/pandoc/archive/${pkgver}.tar.gz")
+source_x86_64=("https://github.com/jgm/pandoc/releases/download/${pkgver}/pandoc-${pkgver}-linux-amd64.tar.gz")
+source_aarch64=("https://github.com/jgm/pandoc/releases/download/${pkgver}/pandoc-${pkgver}-linux-arm64.tar.gz")
-sha256sums=('e00265e5aa56ecb214d12fd7781e87d77abf101dd8d02e15c4d648ad50a5ef80')
-sha256sums_x86_64=('db556c98cf207d2fddc088d12d2e2f367d9401784d4a3e914b068fa895dcf3f0')
-sha256sums_aarch64=('678c09ac4227c88b491f6e75491e6da871fd08d79b8c0f0ee37b611f01ad3d25')
+sha256sums=('c8b360a12b9b2b4be33215f212b444e6110aa7dcfbe49e84f08914855ad9b39a')
+sha256sums_x86_64=('3568b0ab38aa8c7ddce0812fa9f7bea8aa43d1657c5e1e816ed92807719c0e2d')
+sha256sums_aarch64=('23d30e7fcc113aabd85fc426d4b6f924f1b0eebb06c7efc36e9188d117ff58ec')
package() {
cd "${srcdir}/pandoc-${pkgver}"
- # To avoid having to download over a gigabyte of haskell makedepends (400-ish for ghc, plus 750 in libs), we
- # just yoink the binary from static compiled binary distributed by pandoc:
mkdir -p "${pkgdir}/usr/share/pandoc"
cp -R bin share "${pkgdir}/usr"
-
- # We're still missing all the datafiles and so on. We get those from the source tarball...
- cp -R data "${pkgdir}/usr/share/pandoc/"
+ cp -R data citeproc "${pkgdir}/usr/share/pandoc/"
cp COPYRIGHT MANUAL.txt "${pkgdir}/usr/share/pandoc/"
}
+
+# vim: set ts=2 sw=2 et