summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2021-06-14 21:20:47 -0600
committergustawho2021-06-14 21:20:47 -0600
commit2bfdb6900902bb54aa531fc2c741b1431abcc0a3 (patch)
tree7bb0dc3ed164395f7ddd8990a26138a5d40d0d8c
parenteb97688c7e76ee74136b997102418a1015a69f04 (diff)
downloadaur-2bfdb6900902bb54aa531fc2c741b1431abcc0a3.tar.gz
Added aarch64 target
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b20e10d196a5..a8ba1a88793a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,21 @@
pkgbase = pandoc-bin
pkgdesc = Pandoc - executable only, without 750MB Haskell depends/makedepends
pkgver = 2.14.0.2
- pkgrel = 1
+ pkgrel = 2
url = http://pandoc.org
arch = x86_64
- license = GPL
+ arch = aarch64
+ license = GPLv2+
optdepends = texlive-core: for pdf output
provides = pandoc
conflicts = pandoc
replaces = pandoc-static
replaces = pandoc-lite
- source = pandoc-bin-bin-2.14.0.2.tar.gz::https://github.com/jgm/pandoc/releases/download/2.14.0.2/pandoc-2.14.0.2-linux-amd64.tar.gz
source = pandoc-bin-source-2.14.0.2.tar.gz::https://github.com/jgm/pandoc/archive/2.14.0.2.tar.gz
- sha256sums = 2ef6265cdba174152f02a6e3a3f6bbe7e78fbea6e05b44215c2e3d6094abc12d
- sha256sums = 13e0e4e174188a06d25393341d6b44c2a4d38723de46995b78ee788c6cda5526
+ sha512sums = c0b471491a9a60d29414a52285dec88216a343a576e67e59bec16ff96a4d8683a5a1e32e53d5f53c37661d0f10345eca1dd70415f3ae0f75acc475ce17d968a4
+ source_x86_64 = pandoc-bin-bin-2.14.0.2.tar.gz::https://github.com/jgm/pandoc/releases/download/2.14.0.2/pandoc-2.14.0.2-linux-amd64.tar.gz
+ sha512sums_x86_64 = 77ea6e0a24dcdfd0e3a3aa189b75e783c3f2ef1afdeb6d87127e668a71c2920ab27bc849883600b247f9bf3e26811b0bd25887252edb7d26b79317adb27e58ea
+ source_aarch64 = pandoc-bin-bin-2.14.0.2.tar.gz::https://github.com/jgm/pandoc/releases/download/2.14.0.2/pandoc-2.14.0.2-linux-arm64.tar.gz
+ sha512sums_aarch64 = f14e1d8a94a4605df045a52700fd20f374d307ab866205fbf5763b243d14b7819cc97c8a650f3d3f8e228cd7a87d199767faf46bf92a0f8e700984a791b1b8d8
pkgname = pandoc-bin
diff --git a/PKGBUILD b/PKGBUILD
index 849d41194eaf..48c51ae2cbcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
pkgname=pandoc-bin
pkgver=2.14.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="Pandoc - executable only, without 750MB Haskell depends/makedepends"
url="http://pandoc.org"
-license=("GPL")
-arch=('x86_64')
+license=("GPLv2+")
+arch=('x86_64' 'aarch64')
conflicts=("pandoc")
provides=("pandoc")
replaces=('pandoc-static' 'pandoc-lite')
-optdepends=(
- 'texlive-core: for pdf output'
-)
+optdepends=('texlive-core: for pdf output')
-source=(
- "$pkgname-bin-$pkgver.tar.gz::https://github.com/jgm/pandoc/releases/download/${pkgver}/pandoc-${pkgver}-linux-amd64.tar.gz"
+# The binary release doesn't have the datafiles, so we need to yoink those out of the source tarball, too.
+source=("$pkgname-source-$pkgver.tar.gz::https://github.com/jgm/pandoc/archive/${pkgver}.tar.gz")
+source_x86_64=("$pkgname-bin-$pkgver.tar.gz::https://github.com/jgm/pandoc/releases/download/${pkgver}/pandoc-${pkgver}-linux-amd64.tar.gz")
+source_aarch64=("$pkgname-bin-$pkgver.tar.gz::https://github.com/jgm/pandoc/releases/download/${pkgver}/pandoc-${pkgver}-linux-arm64.tar.gz")
- # The binary release doesn't have the datafiles, so we need to yoink those out of the source tarball, too.
- "$pkgname-source-$pkgver.tar.gz::https://github.com/jgm/pandoc/archive/${pkgver}.tar.gz"
-)
-sha256sums=('2ef6265cdba174152f02a6e3a3f6bbe7e78fbea6e05b44215c2e3d6094abc12d'
- '13e0e4e174188a06d25393341d6b44c2a4d38723de46995b78ee788c6cda5526')
+sha512sums=('c0b471491a9a60d29414a52285dec88216a343a576e67e59bec16ff96a4d8683a5a1e32e53d5f53c37661d0f10345eca1dd70415f3ae0f75acc475ce17d968a4')
+sha512sums_x86_64=('77ea6e0a24dcdfd0e3a3aa189b75e783c3f2ef1afdeb6d87127e668a71c2920ab27bc849883600b247f9bf3e26811b0bd25887252edb7d26b79317adb27e58ea')
+sha512sums_aarch64=('f14e1d8a94a4605df045a52700fd20f374d307ab866205fbf5763b243d14b7819cc97c8a650f3d3f8e228cd7a87d199767faf46bf92a0f8e700984a791b1b8d8')
package() {
cd "${srcdir}/pandoc-${pkgver}"