summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2021-04-01 21:06:27 -0700
committergustawho2021-04-01 21:06:27 -0700
commit4a13400ca2d46ce96bce077205ee14c1db2a5539 (patch)
tree50b49e60f974d16939d897dc1da774f0c8fafd2a
parent0cefd1c6430b8e36ab3606df540b1449187109ae (diff)
downloadaur-4a13400ca2d46ce96bce077205ee14c1db2a5539.tar.gz
v2.13
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD36
2 files changed, 20 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73886757768f..301f2b184b4f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pandoc-bin
pkgdesc = Pandoc - executable only, without 750MB Haskell depends/makedepends
- pkgver = 2.11.3
+ pkgver = 2.13
pkgrel = 1
url = http://pandoc.org
arch = x86_64
@@ -10,10 +10,10 @@ pkgbase = pandoc-bin
conflicts = pandoc
replaces = pandoc-static
replaces = pandoc-lite
- source = pandoc-bin-bin-2.11.3.tar.gz::https://github.com/jgm/pandoc/releases/download/2.11.3/pandoc-2.11.3-linux-amd64.tar.gz
- source = pandoc-bin-source-2.11.3.tar.gz::https://github.com/jgm/pandoc/archive/2.11.3.tar.gz
- sha256sums = fdcd77381cd3c41aaf626f0ced64f979062e2e6080f84797278f4c143571ae3f
- sha256sums = 7ee473f2a13f914353d17877ed5a400aa1ea463bbeb66e175e771f50d0319a51
+ source = pandoc-bin-bin-2.13.tar.gz::https://github.com/jgm/pandoc/releases/download/2.13/pandoc-2.13-linux-amd64.tar.gz
+ source = pandoc-bin-source-2.13.tar.gz::https://github.com/jgm/pandoc/archive/2.13.tar.gz
+ sha256sums = 7404aa88a6eb9fbb99d9803b80170a3a546f51959230cc529c66a2ce6b950d4c
+ sha256sums = 16ef030d25006192f77ab1bd1fa403d464fe7cfabc34e7659c1827b69437eac2
pkgname = pandoc-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8de122df6729..f32df43edab5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=pandoc-bin
-pkgver=2.11.3
+pkgver=2.13
pkgrel=1
pkgdesc="Pandoc - executable only, without 750MB Haskell depends/makedepends"
url="http://pandoc.org"
@@ -8,34 +8,28 @@ arch=('x86_64')
conflicts=("pandoc")
provides=("pandoc")
replaces=('pandoc-static' 'pandoc-lite')
-depends=()
optdepends=(
- 'texlive-core: for pdf output'
+ 'texlive-core: for pdf output'
)
source=(
- "$pkgname-bin-$pkgver.tar.gz::https://github.com/jgm/pandoc/releases/download/${pkgver}/pandoc-${pkgver}-linux-amd64.tar.gz"
+ "$pkgname-bin-$pkgver.tar.gz::https://github.com/jgm/pandoc/releases/download/${pkgver}/pandoc-${pkgver}-linux-amd64.tar.gz"
- # The binary release doesn't have the datafiles, so we need to yoink those out of the source tarball, too.
- "$pkgname-source-$pkgver.tar.gz::https://github.com/jgm/pandoc/archive/${pkgver}.tar.gz"
+ # The binary release doesn't have the datafiles, so we need to yoink those out of the source tarball, too.
+ "$pkgname-source-$pkgver.tar.gz::https://github.com/jgm/pandoc/archive/${pkgver}.tar.gz"
)
-sha256sums=('fdcd77381cd3c41aaf626f0ced64f979062e2e6080f84797278f4c143571ae3f'
- '7ee473f2a13f914353d17877ed5a400aa1ea463bbeb66e175e771f50d0319a51')
+sha256sums=('7404aa88a6eb9fbb99d9803b80170a3a546f51959230cc529c66a2ce6b950d4c'
+ '16ef030d25006192f77ab1bd1fa403d464fe7cfabc34e7659c1827b69437eac2')
package() {
- cd "${srcdir}/pandoc-${pkgver}"
+ cd "${srcdir}/pandoc-${pkgver}"
- # To avoid having to download over a gigabyte of haskell makedepends (400-ish for ghc, plus 750 in libs), we
- # just yoink the binary from static compiled binary distributed by pandoc:
- mkdir -p "${pkgdir}/usr/share/pandoc"
- cp -R bin share "${pkgdir}/usr"
+ # To avoid having to download over a gigabyte of haskell makedepends (400-ish for ghc, plus 750 in libs), we
+ # just yoink the binary from static compiled binary distributed by pandoc:
+ mkdir -p "${pkgdir}/usr/share/pandoc"
+ cp -R bin share "${pkgdir}/usr"
-
- # We're still missing all the datafiles and so on. We get those from the source tarball...
- cp -R data "${pkgdir}/usr/share/pandoc/"
- cp COPYRIGHT MANUAL.txt "${pkgdir}/usr/share/pandoc/"
-
- # When pandoc stopped having templates as a submodule, they copied various github turds into their source
- # tree, so let's tidy that up...
- rm -R ${pkgdir}/usr/share/pandoc/data/templates/{.github,README.markdown}
+ # We're still missing all the datafiles and so on. We get those from the source tarball...
+ cp -R data "${pkgdir}/usr/share/pandoc/"
+ cp COPYRIGHT MANUAL.txt "${pkgdir}/usr/share/pandoc/"
}