summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Kitching2017-10-03 09:43:49 +0100
committerChris Kitching2017-10-03 09:45:29 +0100
commite1f83a74ed8a8b58a6701257c742ee3c82dc77df (patch)
tree4d9a42ae7adfc6e105f630800f855367c1e64686
parentd45c2512f725ddef49a4b53d364050b934eabd37 (diff)
downloadaur-e1f83a74ed8a8b58a6701257c742ee3c82dc77df.tar.gz
Merge from pandoc-static
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD57
2 files changed, 54 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c78ad70f5cfb..1a4fcaf8ab80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,21 @@
+# Generated by mksrcinfo v8
+# Tue Oct 3 08:45:25 UTC 2017
pkgbase = pandoc-bin
- pkgdesc = Universal markup converter (Binary build from official deb)
- pkgver = 1.15.2
- pkgrel = 2
- url = http://pandoc.org/
+ pkgdesc = Pandoc - executable only, without 750MB Haskell depends/makedepends
+ pkgver = 1.19.2.1
+ pkgrel = 1
+ url = http://pandoc.org
arch = x86_64
- license = GPL2
- depends = gmp
- depends = zlib
- optdepends = texlive-most: for PDF creation
+ license = GPL
+ depends = cmark
provides = pandoc
- provides = haskell-pandoc-citeproc
- provides = pandoc-cabal
- provides = pandoc-static
- provides = pandoc-rstudio
conflicts = pandoc
- conflicts = haskell-pandoc-citeproc
- conflicts = pandoc-cabal
- conflicts = pandoc-static
- conflicts = pandoc-rstudio
- source_x86_64 = https://github.com/jgm/pandoc/releases/download/1.15.2/pandoc-1.15.2-1-amd64.deb
- md5sums_x86_64 = 8eedd750b0c6825ceb3f365f54c7e226
+ replaces = pandoc-static
+ replaces = pandoc-lite
+ source = https://github.com/jgm/pandoc/releases/download/1.19.2.1/pandoc-1.19.2.1-1-amd64.deb
+ source = https://hackage.haskell.org/package/pandoc-1.19.2.1/pandoc-1.19.2.1.tar.gz
+ sha256sums = db828cbab2a6d0d33f3754c4061a844ae2d1f0a01cbb12c512ef109117595dd2
+ sha256sums = 08692f3d77bf95bb9ba3407f7af26de7c23134e7efcdafad0bdaf9050e2c7801
pkgname = pandoc-bin
diff --git a/PKGBUILD b/PKGBUILD
index a734813b33af..23a5716d83b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,45 @@
-# Maintainer Keerthan Jaic <jckeerthan at gmail dot com>
-# Contributor Artem Klevtsov <a.a.klevtsov at gmail dot com>
-
pkgname=pandoc-bin
-pkgver=1.15.2
-pkgrel=2
-pkgdesc="Universal markup converter (Binary build from official deb)"
-url="http://pandoc.org/"
-license=('GPL2')
+pkgver=1.19.2.1
+pkgrel=1
+pkgdesc="Pandoc - executable only, without 750MB Haskell depends/makedepends"
+url="http://pandoc.org"
+license=("GPL")
arch=('x86_64')
-depends=('gmp' 'zlib')
-optdepends=('texlive-most: for PDF creation')
-provides=('pandoc' 'haskell-pandoc-citeproc' 'pandoc-cabal' 'pandoc-static' 'pandoc-rstudio')
-conflicts=('pandoc' 'haskell-pandoc-citeproc' 'pandoc-cabal' 'pandoc-static' 'pandoc-rstudio')
-source_x86_64=("https://github.com/jgm/pandoc/releases/download/${pkgver}/pandoc-${pkgver}-1-amd64.deb")
-md5sums_x86_64=('8eedd750b0c6825ceb3f365f54c7e226')
+conflicts=("pandoc")
+provides=("pandoc")
+replaces=('pandoc-static' 'pandoc-lite')
+depends=('cmark')
+
+source=(
+ "https://github.com/jgm/pandoc/releases/download/${pkgver}/pandoc-${pkgver}-1-amd64.deb"
+
+ # Note that they use a git submodule for data/templates, so soure tarballs from github are incomplete.
+ # Fetching from hackage gets us a complete tarball without writing our own `git submodule` commands.
+ "https://hackage.haskell.org/package/pandoc-${pkgver}/pandoc-${pkgver}.tar.gz"
+)
+sha256sums=(
+ "db828cbab2a6d0d33f3754c4061a844ae2d1f0a01cbb12c512ef109117595dd2"
+ "08692f3d77bf95bb9ba3407f7af26de7c23134e7efcdafad0bdaf9050e2c7801"
+)
package() {
- bsdtar -xf data.tar.gz -C "${pkgdir}/"
- # This folder only has the license
- rm -r "${pkgdir}"/usr/share/doc
+ cd "${srcdir}"
+
+ # To avoid having to download over a gigabyte of haskell makedepends (400-ish for ghc, plus 750 in libs), we
+ # just yoink the binary from static compiled binary distributed by pandoc:
+ tar -zxf data.tar.gz
+ cp -R usr "${pkgdir}/"
+
+ # Citeproc is provided by a different package, and depends on various other datafiles we don't handle here.
+ rm "${pkgdir}/usr/bin/pandoc-citeproc"
+ rm "${pkgdir}/usr/share/man/man1/pandoc-citeproc.1.gz"
+ rm -R "${pkgdir}/usr/share/doc/pandoc-citeproc"
+
+ # We're still missing all the datafiles and so on. We get those from the source tarball...
+ cd "pandoc-${pkgver}"
+ mkdir -p "${pkgdir}/usr/share/pandoc/"
+
+ cp -R data "${pkgdir}/usr/share/pandoc/"
+ cp COPYRIGHT "${pkgdir}/usr/share/pandoc/COPYRIGHT"
+ cp MANUAL.txt "${pkgdir}/usr/share/pandoc/MANUAL.txt"
}