summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgesh2024-05-02 20:32:46 +0300
committergesh2024-05-02 20:35:38 +0300
commit43e5c556aadc700dba7e5f1f45a30f1c5be78f02 (patch)
treeca01c180843cdc97f486a3f3572c7ad6e29dbea4
parenta4caf652ee05860734b69d00ecbb29da870b3cc6 (diff)
downloadaur-43e5c556aadc700dba7e5f1f45a30f1c5be78f02.tar.gz
Force building with ghc-9.6.5
The default makepkg configuration sets LDFLAGS but not LD. GHC used to take this as its cue to select its own choice of LD. However GHC would *not* check that its choice of LD supports LDFLAGS. This is a problem for dependencies with C components, which get linked using this LD. A fix[1] for this has landed in ghc 9.6.5 on 2024-04-16, and ghc's installed using the current ghcup HEAD (starting with 7a684ad[2]) will have `--disable-ld-override` passed, which also fixes the issue. [1] - https://gitlab.haskell.org/ghc/ghc/-/issues/24565 [2] - https://github.com/haskell/ghcup-hs/issues/1032
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80588db2a31d..9052b297b5f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -40,7 +40,11 @@ EOF
prepare() {
cd "$pkgname"
- stack config set resolver lts-22.13 # ghc-9.6.4
+ stack config set resolver lts-22.19 # ghc-9.6.4
+ echo 'compiler: ghc-9.6.5' >> stack.yaml
+
+ _bumpVer Cabal 3.10.3.0 # 3.12.0.0
+ _bumpVer Cabal-syntax 3.10.3.0 # 3.12.0.0
_bumpVer texmath 0.12.8.8
_bumpVer typst 0.5.0.3
_bumpVer typst-symbols 0.1.6