summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgesh2024-03-21 15:51:47 +0200
committergesh2024-03-21 15:56:44 +0200
commit4b15cd41e362c4b6b07bf2bfdb5e48a09a87cd7e (patch)
tree6242c7eb756a3bbd399d268e7fc51db362009f8d
parent695e0d6393678080ea814a1867ad477184737c16 (diff)
downloadaur-4b15cd41e362c4b6b07bf2bfdb5e48a09a87cd7e.tar.gz
verbump: pandoc 3.1.12.3 (adds yq makedep)
Programmatically edit stack.yaml for version bumping, makes maintenance easier. If yq is undesired, it can be edited out and replaced with a patch -- the edits should be pretty self-explanatory. This bumps the LTS used to 22.13, which point-bumps GHC
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD39
-rw-r--r--ver-bump.patch0
3 files changed, 35 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d119f7198e5..c16fe28351de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = pandoc-crossref-static-git
pkgdesc = Pandoc filter for cross-references (static build)
- pkgver = 0.3.17.0b.r2.ga428e2d
+ pkgver = 0.3.17.0e.r1.g060a049
pkgrel = 1
url = https://github.com/lierdakil/pandoc-crossref
arch = x86_64
license = GPL2
makedepends = stack
makedepends = pandoc
- depends = pandoc=3.1.11.1
- provides = pandoc-crossref=0.3.17.0b
+ makedepends = yq
+ depends = pandoc=3.1.12.3
+ provides = pandoc-crossref=0.3.17.0e
conflicts = pandoc-crossref
replaces = pandoc-crossref-bin
replaces = pandoc-crossref-static
replaces = pandoc-crossref-lite
source = pandoc-crossref-static-git::git+https://github.com/lierdakil/pandoc-crossref.git
- source = ver-bump.patch
sha256sums = SKIP
- sha256sums = e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
pkgname = pandoc-crossref-static-git
diff --git a/PKGBUILD b/PKGBUILD
index e994e9e50cc8..17c5388f8178 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,10 @@
pkgname=pandoc-crossref-static-git
_pkgname="${pkgname%-static-git}"
-pkgver=0.3.17.0b.r2.ga428e2d
+pkgver=0.3.17.0e.r1.g060a049
_pandoc_type=version
-_pandoc_ver=3.1.11.1
-_pandoc_commit=714ed52213fd6649350ccebe741caefc11cc5a04
+_pandoc_ver=3.1.12.3
+_pandoc_commit=b1e2e452deb36e050c0b81c4c2351d5a829d2977
pkgrel=1
pkgdesc="Pandoc filter for cross-references (static build)"
url="https://github.com/lierdakil/pandoc-crossref"
@@ -18,19 +18,42 @@ conflicts=("pandoc-crossref")
provides=("$_pkgname=${pkgver%%.r*}")
replaces=('pandoc-crossref-bin' 'pandoc-crossref-static' 'pandoc-crossref-lite')
depends=("pandoc=$_pandoc_ver")
-makedepends=('stack' 'pandoc')
-source=("$pkgname::git+$url.git" ver-bump.patch)
-sha256sums=('SKIP'
- 'e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855')
+makedepends=('stack' 'pandoc' 'yq')
+source=("$pkgname::git+$url.git")
+sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+_bumpVer() {
+ yq -i --yaml-output --arg pkg "$1" --arg ver "$2" \
+ "$(cat <<'EOF'
+ (."extra-deps".[]
+ | strings
+ | select(match("^\($pkg)-[0-9.]+")))
+ |= $pkg + "-" + $ver
+EOF
+)" stack.yaml
+}
+
prepare() {
cd "$pkgname"
- patch --forward --strip=1 --input="${srcdir}/ver-bump.patch"
+ stack config set resolver lts-22.13 # ghc-9.6.4
+
+ _bumpVer commonmark 0.2.6
+ _bumpVer commonmark-extensions 0.2.5.4
+ _bumpVer djot 0.1.1.3
+ _bumpVer pandoc 3.1.12.3
+ _bumpVer pandoc-cli 3.1.12.3
+ _bumpVer skylighting 0.14.1.1
+ _bumpVer skylighting-core 0.14.1.1
+ _bumpVer texmath 0.12.8.7
+ _bumpVer toml-parser 2.0.0.0
+ _bumpVer typst 0.5.0.2
+ _bumpVer zip-archive 0.4.3.1
+
# if pandoc updates break the golden tests, cf
# https://github.com/lierdakil/pandoc-crossref/pull/403#issuecomment-1732434519
# for how to bump
diff --git a/ver-bump.patch b/ver-bump.patch
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/ver-bump.patch
+++ /dev/null