summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoron Behar2018-01-18 16:58:41 +0200
committerDoron Behar2018-01-18 16:58:41 +0200
commit782f38cf53eea3922ba874bea326260755c8774b (patch)
treec71bcad80e05d2509cba58f10aae2ab350d27893
parent6f5af55754986b811a9c085d7f1c7add68a2c9f8 (diff)
downloadaur-782f38cf53eea3922ba874bea326260755c8774b.tar.gz
Update to `v0.3.0.1`.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 674522a3e6f2..37950dc61e42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pandoc-crossref-bin
pkgdesc = Pandoc Cross References - executable only, without 750MB Haskell depends/makedepends
- pkgver = 0.3.0.0
+ pkgver = 0.3.0.1
pkgrel = 1
url = https://hackage.haskell.org/package/pandoc-crossref
arch = x86_64
@@ -10,8 +10,8 @@ pkgbase = pandoc-crossref-bin
conflicts = pandoc-crossref
replaces = pandoc-crossref-static
replaces = pandoc-crossref-lite
- source = https://github.com/lierdakil/pandoc-crossref/releases/download/v0.3.0.0/linux-ghc8-pandoc-2-0.tar.gz
- sha256sums = 1ad617888ebee9b1a45bf0100184d0403edb2ad4d3d65ec270fc0c0d7e324f21
+ source = https://github.com/lierdakil/pandoc-crossref/releases/download/v0.3.0.1/linux-ghc82-pandoc20.tar.gz
+ sha256sums = 2b2faead48f05699336690f7a82a1926c64893019d16139091c6ea2cb4d6a0f0
pkgname = pandoc-crossref-bin
diff --git a/PKGBUILD b/PKGBUILD
index 719791169ceb..80459323655a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
pkgname=pandoc-crossref-bin
-pkgver=0.3.0.0
-pandoc_pkgver=2-0
+pkgver=0.3.0.1
+pandoc_pkgver=20
+ghc_pkgver=82
pkgrel=1
pkgdesc="Pandoc Cross References - executable only, without 750MB Haskell depends/makedepends"
url="https://hackage.haskell.org/package/pandoc-crossref"
@@ -12,10 +13,10 @@ replaces=('pandoc-crossref-static' 'pandoc-crossref-lite')
depends=('pandoc')
source=(
- "https://github.com/lierdakil/pandoc-crossref/releases/download/v${pkgver}/linux-ghc8-pandoc-${pandoc_pkgver}.tar.gz"
+ "https://github.com/lierdakil/pandoc-crossref/releases/download/v${pkgver}/linux-ghc${ghc_pkgver}-pandoc${pandoc_pkgver}.tar.gz"
)
sha256sums=(
- "1ad617888ebee9b1a45bf0100184d0403edb2ad4d3d65ec270fc0c0d7e324f21"
+ "2b2faead48f05699336690f7a82a1926c64893019d16139091c6ea2cb4d6a0f0"
)
package() {
@@ -23,7 +24,7 @@ package() {
# To avoid having to download over a gigabyte of haskell makedepends (400-ish for ghc, plus 750 in libs), we
# just yoink the binary from static compiled binary distributed by pandoc:
- tar -zxf "linux-ghc8-pandoc-${pandoc_pkgver}.tar.gz"
+ tar -zxf "linux-ghc${ghc_pkgver}-pandoc${pandoc_pkgver}.tar.gz"
mkdir -p "${pkgdir}/usr/bin"
cp pandoc-crossref "${pkgdir}/usr/bin/"