summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Żok2020-09-03 14:28:44 +0200
committerTomasz Żok2020-09-03 14:28:44 +0200
commit1000cff6123056e0ff736319d961a2a146ebdb7d (patch)
treee771b40b43fd729b1ff42152662ea3b822d1d5f7
parentdf27dcbc9b0af75f3ba867a35f4b457bf601be3c (diff)
downloadaur-1000cff6123056e0ff736319d961a2a146ebdb7d.tar.gz
Update to work with pandoc-types 1.21
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
-rw-r--r--pandoc-include-code.cabal.patch28
3 files changed, 45 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3638179ffb10..3ce0c8bf55ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pandoc-include-code
pkgdesc = A pandoc filter for including code from source files
pkgver = 1.5.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/owickstrom/pandoc-include-code
arch = i686
arch = x86_64
@@ -12,7 +12,9 @@ pkgbase = pandoc-include-code
depends = haskell-text
depends = haskell-unordered-containers
source = https://hackage.haskell.org/packages/archive/pandoc-include-code/1.5.0.0/pandoc-include-code-1.5.0.0.tar.gz
+ source = pandoc-include-code.cabal.patch
sha512sums = 1d2cc5fceb3183fe94e8a1ec3a641918f6531c961a1477f36686ee70b621325ff94e3006d17921ed55a1d53087d0ae614710c5a23913bc9a4419865061991018
+ sha512sums = SKIP
pkgname = pandoc-include-code
diff --git a/PKGBUILD b/PKGBUILD
index 913cbba8186b..4fc8c002db64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,30 @@
-# Maintainer: Em Zhan <zqianem at gmail dot com>
+# Maintainer: Tomasz Zok <tomasz dot zok at gmail dot com>
+# Prev Maintainer: Em Zhan <zqianem at gmail dot com>
# Contributor: Emanuel Couto <unit73e at gmail dot com>
_hkgname=pandoc-include-code
pkgname=pandoc-include-code
pkgver=1.5.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="A pandoc filter for including code from source files"
url="https://github.com/owickstrom/pandoc-include-code"
license=('MPL2')
arch=('i686' 'x86_64')
depends=('ghc-libs' 'haskell-pandoc-types' 'haskell-text' 'haskell-unordered-containers')
makedepends=('ghc')
-source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
-sha512sums=('1d2cc5fceb3183fe94e8a1ec3a641918f6531c961a1477f36686ee70b621325ff94e3006d17921ed55a1d53087d0ae614710c5a23913bc9a4419865061991018')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz"
+ pandoc-include-code.cabal.patch)
+sha512sums=('1d2cc5fceb3183fe94e8a1ec3a641918f6531c961a1477f36686ee70b621325ff94e3006d17921ed55a1d53087d0ae614710c5a23913bc9a4419865061991018'
+ SKIP)
+
+prepare() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+ patch -p0 < ../pandoc-include-code.cabal.patch
+}
build() {
cd "${srcdir}/${_hkgname}-${pkgver}"
-
+
runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
--prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
--dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
@@ -29,7 +37,7 @@ build() {
package() {
cd "${srcdir}/${_hkgname}-${pkgver}"
-
+
install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
runhaskell Setup copy --destdir="${pkgdir}"
diff --git a/pandoc-include-code.cabal.patch b/pandoc-include-code.cabal.patch
new file mode 100644
index 000000000000..30cae1bfc048
--- /dev/null
+++ b/pandoc-include-code.cabal.patch
@@ -0,0 +1,28 @@
+--- pandoc-include-code.cabal.bak 2020-09-03 12:02:34.542584727 +0200
++++ pandoc-include-code.cabal 2020-09-03 12:02:23.252166789 +0200
+@@ -36,14 +36,14 @@
+ , filepath
+ , text >= 1.2 && < 2
+ , mtl >= 2.2 && < 3
+- , pandoc-types >= 1.20 && <= 1.20
++ , pandoc-types >= 1.20
+
+
+ executable pandoc-include-code
+ hs-source-dirs: filter
+ main-is: Main.hs
+ build-depends: base >= 4 && < 5
+- , pandoc-types >= 1.20 && <= 1.20
++ , pandoc-types >= 1.20
+ , pandoc-include-code
+
+ test-suite filter-tests
+@@ -53,7 +53,7 @@
+ , Paths_pandoc_include_code
+ main-is: Driver.hs
+ build-depends: base >= 4 && < 5
+- , pandoc-types >= 1.20 && <= 1.20
++ , pandoc-types >= 1.20
+ , pandoc-include-code
+ , tasty
+ , tasty-hunit