summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin McCorkell2015-11-19 23:57:56 +0000
committerRobin McCorkell2015-11-19 23:59:40 +0000
commite408e23aa956d0a91aa6690f01da0302d72f2cc1 (patch)
tree9d3018a22eaedd1c3c7a5d3164251adf62300ec6
downloadaur-e408e23aa956d0a91aa6690f01da0302d72f2cc1.tar.gz
Initial version 0.1.0.2
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
-rw-r--r--cabal.patch13
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4a0d2ac77b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = pandoc-plantuml-filter-git
+ pkgdesc = Pandoc filter for PlantUML code blocks
+ pkgver = 0.1.0.2
+ pkgrel = 1
+ url = https://github.com/kbonne/pandoc-plantuml-filter
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = cabal-install
+ makedepends = haskell-pandoc-types
+ depends = pandoc
+ depends = plantuml
+ provides = pandoc-plantuml-filter
+ conflicts = pandoc-plantuml-filter
+ source = git+https://github.com/kbonne/pandoc-plantuml-filter.git
+ source = cabal.patch
+ md5sums = SKIP
+ md5sums = 38558ee9e9dddd252f5c46d0e8e273a6
+
+pkgname = pandoc-plantuml-filter-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8449f7ae4b38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Robin McCorkell <robin@mccorkell.me.uk>
+pkgname=pandoc-plantuml-filter-git
+pkgver=0.1.0.2
+pkgrel=1
+pkgdesc="Pandoc filter for PlantUML code blocks"
+arch=('any')
+url="https://github.com/kbonne/pandoc-plantuml-filter"
+license=('GPL2')
+depends=(pandoc plantuml)
+makedepends=(git cabal-install haskell-pandoc-types)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(
+ 'git+https://github.com/kbonne/pandoc-plantuml-filter.git'
+ 'cabal.patch'
+)
+md5sums=(
+ 'SKIP'
+ '38558ee9e9dddd252f5c46d0e8e273a6'
+)
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ patch -p1 -i "$srcdir/cabal.patch"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ cabal build
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -D dist/build/pandoc-plantuml-filter/pandoc-plantuml-filter "$pkgdir"/usr/bin/pandoc-plantuml-filter
+}
diff --git a/cabal.patch b/cabal.patch
new file mode 100644
index 000000000000..0fa3dc0b75a7
--- /dev/null
+++ b/cabal.patch
@@ -0,0 +1,13 @@
+diff --git a/pandoc-plantuml-filter.cabal b/pandoc-plantuml-filter.cabal
+index ca19824..11bbe95 100644
+--- a/pandoc-plantuml-filter.cabal
++++ b/pandoc-plantuml-filter.cabal
+@@ -60,7 +60,7 @@ executable pandoc-plantuml-filter
+ -- other-extensions:
+
+ -- Other library packages from which modules are imported.
+- build-depends: base >=4.6 && <4.8
++ build-depends: base >=4.6 && <5
+ , pandoc-types
+ , utf8-string
+ , SHA