summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-11-10 12:09:13 +0300
committerCaleb Maclennan2020-11-10 12:09:13 +0300
commit4d0a57198f7260346e2fb69c271aeafbd076dd3e (patch)
treeca42cf2a47cf7e22ca35c159dfc7ec541095b00f
parentb60b715b158d006e73283a6a8e7ff176dcad2005 (diff)
downloadaur-4d0a57198f7260346e2fb69c271aeafbd076dd3e.tar.gz
upgpkg: pandoc-sile-git 2.11.1.1.r8.g9c04c2e-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d8506c788f8..0475b719a1fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pandoc-sile-git
pkgdesc = Conversion between markup formats (sile fork, static build)
- pkgver = 2.9.2.r347.gc2764508e
+ pkgver = 2.11.1.1.r8.g9c04c2e
pkgrel = 1
url = https://pandoc.org
arch = x86_64
@@ -9,11 +9,11 @@ pkgbase = pandoc-sile-git
optdepends = pandoc-citeproc: for citation rendering with pandoc-citeproc filter
optdepends = pandoc-crossref: for numbering figures, equations, tables and cross-references to them with pandoc-crossref filter
optdepends = texlive-core: for pdf output
- provides = pandoc
+ provides = pandoc=2.11.1.1
conflicts = haskell-pandoc
conflicts = pandoc
replaces = haskell-pandoc
- source = git://github.com/alerque/pandoc.git#branch=sile-2.10.1
+ source = git://github.com/alerque/pandoc.git#branch=sile-2.11.1.1
sha512sums = SKIP
pkgname = pandoc-sile-git
diff --git a/PKGBUILD b/PKGBUILD
index faf117d73207..f6c6e2b25222 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
_pkgname=pandoc
pkgname=$_pkgname-sile-git
-_pkgver=2.10.1
-pkgver=2.9.2.r347.gc2764508e
+_pkgver=2.11.1.1
+pkgver=2.11.1.1.r8.g9c04c2e
pkgrel=1
pkgdesc='Conversion between markup formats (sile fork, static build)'
url='https://pandoc.org'
@@ -16,19 +16,19 @@ optdepends=('pandoc-citeproc: for citation rendering with pandoc-citeproc filter
'texlive-core: for pdf output')
conflicts=('haskell-pandoc' "$_pkgname")
replaces=('haskell-pandoc')
-provides=("$_pkgname")
+provides=("$_pkgname=$_pkgver")
makedepends=('stack')
source=("git://github.com/alerque/$_pkgname.git#branch=sile-${_pkgver}")
sha512sums=('SKIP')
pkgver() {
cd "$_pkgname"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags --abbrev=7 --always HEAD |
+ sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd "$_pkgname"
-
# TODO: find a better solution
sed -i "s|let env' = dynlibEnv ++ |let env' = dynlibEnv ++ [(\"LD_LIBRARY_PATH\", \"$PWD/dist/build\")] ++ |" test/Tests/Command.hs
}