summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-19 15:35:08 +0300
committerCaleb Maclennan2020-02-19 15:35:42 +0300
commit748c0664ddd896ec3bf49b340fee15b857b6e419 (patch)
treedde51d573a4a974240899679d98276451e959e23
parent2dd8d8c93712259285e443c1ab9aa708fd07aa56 (diff)
downloadaur-748c0664ddd896ec3bf49b340fee15b857b6e419.tar.gz
Get back to static builds, minimal changes from [community] PKGBUILD
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1f420047d83..1a58cd02b0df 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pandoc-sile-git
pkgdesc = Conversion between markup formats (sile fork)
pkgver = 2.9.2.r8.g78db4f240
- pkgrel = 1
+ pkgrel = 2
url = https://pandoc.org
arch = x86_64
license = GPL
@@ -67,7 +67,6 @@ pkgbase = pandoc-sile-git
optdepends = pandoc-crossref: for numbering figures, equations, tables and cross-references to them with pandoc-crossref filter
optdepends = texlive-core: for pdf output
provides = pandoc
- provides = pandoc-sile
conflicts = haskell-pandoc
conflicts = pandoc
replaces = haskell-pandoc
diff --git a/PKGBUILD b/PKGBUILD
index 9222f03ea1ab..d83dc2474895 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _pkgname=pandoc
pkgname=$_pkgname-sile-git
_pkgver=2.9.2
pkgver=2.9.2.r8.g78db4f240
-pkgrel=1
+pkgrel=2
pkgdesc='Conversion between markup formats (sile fork)'
url='https://pandoc.org'
license=('GPL')
@@ -27,7 +27,7 @@ depends=('ghc-libs' 'haskell-http' 'haskell-juicypixels' 'haskell-sha' 'haskell-
optdepends=('pandoc-citeproc: for citation rendering with pandoc-citeproc filter'
'pandoc-crossref: for numbering figures, equations, tables and cross-references to them with pandoc-crossref filter'
'texlive-core: for pdf output')
-provides=('pandoc' 'pandoc-sile')
+provides=('pandoc')
conflicts=('haskell-pandoc' 'pandoc')
replaces=('haskell-pandoc')
makedepends=('ghc' 'haskell-diff' 'haskell-tasty' 'haskell-tasty-hunit' 'haskell-tasty-lua'
@@ -44,6 +44,9 @@ pkgver() {
prepare() {
cd "$_pkgname"
+ # SILE fork isn't expected to pass some tests yet
+ sed -i -e 's!--\(enable-\)\?tests\? ! !' Makefile
+
# TODO: find a better solution
sed -i "s|let env' = dynlibEnv ++ |let env' = dynlibEnv ++ [(\"LD_LIBRARY_PATH\", \"$PWD/dist/build\")] ++ |" test/Tests/Command.hs
}
@@ -54,7 +57,7 @@ build() {
runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
--prefix=/usr --docdir="/usr/share/doc/${pkgbase}" --datasubdir="$_pkgname" --enable-tests \
--dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
- -f-trypandoc -f-embed_data_files
+ -f-trypandoc -f-embed_data_files -f-static
runhaskell Setup build
runhaskell Setup register --gen-script
runhaskell Setup unregister --gen-script
@@ -64,7 +67,7 @@ build() {
check() {
cd "$_pkgname"
- # LC_CTYPE=en_US.UTF-8 runhaskell Setup test || warning "Tests failed"
+ LC_CTYPE=en_US.UTF-8 runhaskell Setup test || warning "Tests failed"
}
package() {
@@ -72,6 +75,6 @@ package() {
install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${_pkgname}.sh"
install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${_pkgname}.sh"
runhaskell Setup copy --destdir="${pkgdir}"
- # rm "${pkgdir}/usr/share/doc/${_pkgname}/COPYING.md"
+ rm "${pkgdir}/usr/share/doc/${pkgname}/COPYING.md"
install -Dm644 man/pandoc.1 "${pkgdir}"/usr/share/man/man1/pandoc.1
}