summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2022-03-31 22:02:59 +0800
committertaotieren2022-03-31 22:02:59 +0800
commitc83ddab0c29447d656fa53b5853e32bde7086206 (patch)
tree486858a786628b9118f7e8664a15817050651a66
downloadaur-c83ddab0c29447d656fa53b5853e32bde7086206.tar.gz
Update v0.0.5
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD142
-rw-r--r--pandownload-wine.install15
4 files changed, 182 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2eb77670eed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = pandownload-wine
+ pkgdesc = 本软件为 PanDownload 的众多修改版中的一个,鉴于找不到比 PanDownload 更优秀的百度网盘多账号管理软件,所以对 PanDownload 进行了一些基础功能上的修复。
+ pkgver = 0.0.5
+ pkgrel = 1
+ url = https://pandownload.net/
+ install = pandownload-wine.install
+ arch = any
+ license = unknow
+ makedepends = unarchiver
+ depends = wine
+ depends = wqy-microhei
+ depends = winetricks
+ depends = wine-mono
+ depends = wine-gecko
+ optdepends = wine-mono-gecko-version-fix: Fix the version numbers of wine-mono and wine-gecko files to solve the dialog box that pops up when starting wine.
+ provides = PanDownload
+ noextract = PanDownload_公测版_0.0.5_ALL.zip
+ options = !strip
+ source = local://PanDownload_公测版_0.0.5_ALL.zip
+ source = pandownload-wine.install
+ sha256sums = b57c1113d037b569c30525cfa5c9fa47fe30eee36cc4e424c830fef8497ac1d1
+ sha256sums = 50f2d42d213da6a4567e99184571906f86377c8001c6a0e0a490338110279163
+
+pkgname = pandownload-wine
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdf558707884
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,142 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgname=pandownload-wine
+pkgver=0.0.5
+pkgrel=1
+pkgdesc="本软件为 PanDownload 的众多修改版中的一个,鉴于找不到比 PanDownload 更优秀的百度网盘多账号管理软件,所以对 PanDownload 进行了一些基础功能上的修复。"
+arch=('any')
+url="https://pandownload.net/"
+license=('unknow')
+provides=('PanDownload')
+conflicts=()
+replaces=()
+depends=('wine' 'wqy-microhei' 'winetricks' 'wine-mono' 'wine-gecko')
+optdepends=("wine-mono-gecko-version-fix: Fix the version numbers of wine-mono and wine-gecko files to solve the dialog box that pops up when starting wine.")
+makedepends=('unarchiver')
+backup=()
+options=('!strip')
+install=${pkgname}.install
+
+_pkg_file_name=PanDownload_公测版_${pkgver}_ALL.zip
+_DOWNLOADS_DIR=`xdg-user-dir DOWNLOAD`
+if [ ! -f ${PWD}/${_pkg_file_name} ]; then
+ if [ -f $_DOWNLOADS_DIR/${_pkg_file_name} ]; then
+ ln -sfn $_DOWNLOADS_DIR/${_pkg_file_name} ${PWD}
+ else
+ msg2 ""
+ msg2 "Package not found!"
+ msg2 "The package can be downloaded here: ${url}"
+ msg2 "Please remember to put a downloaded package ${_pkg_file_name} into the build directory ${PWD} or $_DOWNLOADS_DIR"
+ msg2 ""
+ fi
+fi
+
+source=("local://${_pkg_file_name}"
+ "${pkgname}.install")
+sha256sums=('b57c1113d037b569c30525cfa5c9fa47fe30eee36cc4e424c830fef8497ac1d1'
+ '50f2d42d213da6a4567e99184571906f86377c8001c6a0e0a490338110279163')
+noextract=("PanDownload_公测版_${pkgver}_ALL.zip")
+
+# prepare() {
+# unar -e GBK "${srcdir}/PanDownload_公测版_${pkgver}_ALL.zip"
+# }
+
+package() {
+ export LC_CTYPE="zh_CN.UTF-8"
+
+ _path="opt/${pkgname%-wine}"
+ _ftname="wqy-microhei.ttc"
+
+ install -dm0755 "${pkgdir}/${_path}/${pkgname%-wine}"
+
+# cp -ra "${srcdir}/${pkgname%-wine}-${pkgver}/${pkgname%-wine}-${pkgver}.exe" "${pkgdir}/${_path}/${pkgname%-wine}"
+ bsdtar -xf "${srcdir}/PanDownload_公测版_${pkgver}_ALL.zip" -C "${pkgdir}/${_path}/${pkgname%-wine}"
+
+ find "${pkgdir}/${_path}" -type f -exec chmod 644 "{}" \;
+ find "${pkgdir}/${_path}" -type d -exec chmod 755 "{}" \;
+
+ install -Dm0644 /dev/stdin "${pkgdir}/${_path}/${pkgname%-wine}/regpatch.reg" << EOF
+REGEDIT4
+
+[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\FontLink\SystemLink]
+"Lucida Sans Unicode"="${_ftname}"
+"Microsoft Sans Serif"="${_ftname}"
+"MS Sans Serif"="${_ftname}"
+"Tahoma"="${_ftname}"
+"Tahoma Bold"="${_ftname}"
+"SimSun"="${_ftname}"
+"Arial"="${_ftname}"
+"Arial Black"="${_ftname}"
+"Lucida Sans Unicode"=str(7):"${_ftname}"
+"Microsoft Sans Serif"=str(7):"${_ftname}"
+"Tahoma"=str(7):"${_ftname}"
+"Lucida Sans Unicode"="${_ftname}"
+"Microsoft Sans Serif"="${_ftname}"
+"Microsoft YaHei"="${_ftname}"
+"微软雅黑"="${_ftname}"
+"宋体"="${_ftname}"
+"新細明體"="${_ftname}"
+"DFKai-SB"="${_ftname}"
+"FangSong"="${_ftname}"
+"KaiTi"="${_ftname}"
+"Microsoft JhengHei"="${_ftname}"
+"Microsoft YaHei"="${_ftname}"
+"MingLiU"="${_ftname}"
+"NSimSun"="${_ftname}"
+"PMingLiU"="${_ftname}"
+"SimHei"="${_ftname}"
+"SimKai"="${_ftname}"
+"SimSun"="${_ftname}"
+
+[HKEY_CURRENT_USER\Software\Wine\X11 Driver]
+"ClientSideAntiAliasWithCore"="N"
+"ClientSideAntiAliasWithRender"="N"
+"ClientSideWithRender"="N"
+
+[HKEY_CURRENT_USER\Control Panel\Desktop]
+"FontSmoothing"="2"
+"FontSmoothingType"=dword:00000002
+"FontSmoothingGamma"=dword:00000578
+"FontSmoothingOrientation"=dword:00000001
+
+EOF
+
+ install -Dm0755 /dev/stdin "${pkgdir}/usr/bin/${pkgname%-wine}" << EOF
+#!/bin/bash
+export LC_CTYPE="zh_CN.UTF-8"
+export WINEARCH=win32 WINEPREFIX="$HOME/.${pkgname%-wine}/wine"
+
+if [ ! -d "$HOME"/.${pkgname%-wine} ] ; then
+ mkdir -p "$HOME"/.${pkgname%-wine}/wine || exit 1
+
+ cp -r /${_path}/${pkgname%-wine}/regpatch.reg "$HOME"/.${pkgname%-wine}/wine || exit 1
+
+ cp -r /${_path}/${pkgname%-wine}/Pandownload.exe "$HOME"/.${pkgname%-wine}/${pkgname%-wine} || exit 1
+ cp -r /${_path}/${pkgname%-wine}/libcurl.dll "$HOME"/.${pkgname%-wine}/libcurl.dll || exit 1
+ cp -r /${_path}/${pkgname%-wine}/lua53.dll "$HOME"/.${pkgname%-wine}/lua53.dll || exit 1
+ cp -r /${_path}/${pkgname%-wine}/PanData "$HOME"/.${pkgname%-wine}/PanData || exit 1
+fi
+
+if [ ! -f "$HOME"/.${pkgname%-wine}/regpatchok ] ; then
+ touch "$HOME"/.${pkgname%-wine}/regpatchok || exit 1
+ cd "$HOME"/.${pkgname%-wine}/wine && regedit regpatch.reg && wineserver -k
+# winetricks -q mfc42
+fi
+
+wine "$HOME"/.${pkgname%-wine}/${pkgname%-wine} "\$@"
+EOF
+
+ install -Dm0644 /dev/stdin "${pkgdir}/usr/share/applications/${pkgname%-wine}.desktop" << EOF
+[Desktop Entry]
+Name=${pkgname%-wine}
+Name[zh_CN]=${pkgname%-wine}
+Comment=${pkgdesc}
+#MimeType=application/x-${pkgname%-wine};
+Exec=${pkgname%-wine} %f
+Type=Application
+Categories=Development;Tool;
+Terminal=false
+Icon=${pkgname%-wine}.png
+Version=${pkgver}
+EOF
+}
diff --git a/pandownload-wine.install b/pandownload-wine.install
new file mode 100644
index 000000000000..ae97ea15e6ed
--- /dev/null
+++ b/pandownload-wine.install
@@ -0,0 +1,15 @@
+info() {
+ echo -e "本软件为 PanDownload 的众多修改版中的一个"
+}
+post_install() {
+ info
+}
+post_upgrade() {
+ echo "deleting the pandownload bottle..."
+ find /home -maxdepth 2 -name ".pandownload" -exec rm -rf {} \;
+ info
+}
+pre_remove() {
+ echo "deleting the pandownload bottle..."
+ find /home -maxdepth 2 -name ".pandownload" -exec rm -rf {} \;
+}