summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-07-13 15:12:15 +0200
committerLubosz Sarnecki2015-07-13 15:12:15 +0200
commit21c6a1252dcd3b8850cbc65004f6f038b3c38ffa (patch)
treefd956d12f147922862c4e102267b2a1c3271cb73
downloadaur-21c6a1252dcd3b8850cbc65004f6f038b3c38ffa.tar.gz
import from aur3, update to pacman4 git build
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD50
-rw-r--r--pango.install21
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40ef074c246b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = pango
+ pkgdesc = A library for layout and rendering of text
+ pkgver = 1.37.1.3744.65214f2
+ pkgrel = 1
+ url = http://gnome.org/
+ install = pango.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = gobject-introspection
+ makedepends = libxt
+ makedepends = gtk-doc
+ depends = glib2-git
+ depends = cairo-git
+ depends = libxft
+ depends = libthai
+ depends = freetype2
+ depends = harfbuzz-git
+ depends = fontconfig-git
+ provides = pango=1.37.1.3744.65214f2
+ conflicts = pango
+ options = !libtool
+ options = strip
+ options = debug
+ source = git+git://git.gnome.org/pango
+ source = pango.install
+ sha256sums = SKIP
+ sha256sums = f1e5094509e01a9eeefd29830e8be7c8b9fab4eafccd4daac4cd50c9a811c992
+
+pkgname = pango-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b17c9b0aa6fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+# Contributor: mariusz - myswiat <my.swiat@o2.pl>
+
+pkgbase=pango
+pkgname=${pkgbase}-git
+pkgver=1.37.1.3744.65214f2
+pkgrel=1
+pkgdesc="A library for layout and rendering of text"
+arch=('i686' 'x86_64')
+url="http://gnome.org/"
+license=('LGPL')
+depends=('glib2-git' 'cairo-git' 'libxft' 'libthai' 'freetype2'
+ 'harfbuzz-git' 'fontconfig-git')
+makedepends=('gobject-introspection' 'libxt' 'gtk-doc')
+provides=("${pkgbase}=${pkgver}")
+conflicts=("${pkgbase}")
+install=${pkgbase}.install
+options=('!libtool' 'strip' 'debug')
+
+source=("git+git://git.gnome.org/pango" "pango.install")
+
+sha256sums=("SKIP" "f1e5094509e01a9eeefd29830e8be7c8b9fab4eafccd4daac4cd50c9a811c992")
+
+subver() {
+ PREFIX="m4_define(\[pango_version_$1\], \["
+ echo $(grep "$PREFIX" configure.ac | eval sed "'s/$PREFIX//'" | sed 's/\])//')
+}
+
+pkgver() {
+ cd $pkgbase
+ hash=$(git log --pretty=format:'%h' -n 1)
+ revision=$(git rev-list --count HEAD)
+ echo $(subver major).$(subver minor).$(subver micro).$revision.$hash
+}
+
+build() {
+ cd $pkgbase
+ ./autogen.sh \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --with-included-modules=basic-fc
+ make
+}
+
+package() {
+ cd $pkgbase
+ make DESTDIR=$pkgdir install
+ install -m755 -d "${pkgdir}/etc/pango"
+}
diff --git a/pango.install b/pango.install
new file mode 100644
index 000000000000..73b0f5bf1592
--- /dev/null
+++ b/pango.install
@@ -0,0 +1,21 @@
+# arg 1: the new package version
+post_install() {
+ # we need to ldconfig first, in case xfree86's libs aren't
+ # in ld.so.cache yet
+ sbin/ldconfig -r .
+ usr/bin/pango-querymodules >etc/pango/pango.modules
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ if [ -f usr/etc/pango/pango.modules ]; then
+ rm usr/etc/pango/pango.modules
+ fi
+ post_install $1
+}
+
+# arg 1: the old package version
+pre_remove() {
+ rm etc/pango/pango.modules
+}