summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2019-08-07 23:47:23 -0400
committerVincent Grande2019-08-07 23:47:23 -0400
commit2d089347ea920484dfb3634f65e757aa3a7a0961 (patch)
tree2649b4d5db104e9b4fcd233c0398e503ca009153
parent5bcc5b8586a182440eddbb69e692f54840f57030 (diff)
downloadaur-2d089347ea920484dfb3634f65e757aa3a7a0961.tar.gz
things
-rw-r--r--.SRCINFO26
-rwxr-xr-x[-rw-r--r--]PKGBUILD53
-rw-r--r--pango.install21
3 files changed, 36 insertions, 64 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8222b0527d25..8de4248d38fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,23 @@
pkgbase = pango-git
pkgdesc = A library for layout and rendering of text
- pkgver = 1.44.r31.g1311cfec
+ pkgver = 1.44.3
pkgrel = 1
- url = http://gnome.org/
- install = pango.install
- arch = i686
+ epoch = 1
+ url = https://www.pango.org/
arch = x86_64
license = LGPL
makedepends = gobject-introspection
- makedepends = libxt
- makedepends = gtk-doc
- makedepends = meson
makedepends = git
- depends = glib2
+ makedepends = meson
+ depends = libthai
depends = cairo
depends = libxft
- depends = libthai
- depends = freetype2
depends = harfbuzz
- depends = fontconfig
- provides = pango=1.44.r31.g1311cfec
+ depends = fribidi
+ provides = pango
conflicts = pango
- options = !libtool
- options = strip
- options = debug
- source = git+https://gitlab.gnome.org/GNOME/pango
- source = pango.install
+ source = git+https://gitlab.gnome.org/GNOME/pango.git
sha256sums = SKIP
- sha256sums = 1e69feead9d9e5a76e7e0dc1b3da3b8938f65f58c02449478900559be50e9ac7
pkgname = pango-git
diff --git a/PKGBUILD b/PKGBUILD
index e50b824e26d4..4a9b256b185f 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,40 @@
-# Contributor: Lubosz Sarnecki <lubosz@gmail.com>
-# Contributor: mariusz - myswiat <my.swiat@o2.pl>
-# Contributor:Jan de Groot <jgc@archlinux.org>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
-_realname=pango
-pkgname=$_realname-git
-pkgver=1.44.r31.g1311cfec
+pkgname=pango-git
+pkgver=1.44.3
pkgrel=1
+epoch=1
pkgdesc="A library for layout and rendering of text"
-arch=('i686' 'x86_64')
-url="http://gnome.org/"
-license=('LGPL')
-depends=('glib2' 'cairo' 'libxft' 'libthai' 'freetype2' 'harfbuzz' 'fontconfig')
-makedepends=('gobject-introspection' 'libxt' 'gtk-doc' 'meson' 'git')
-provides=("${_realname}=${pkgver}")
-conflicts=("${_realname}")
-install=${_realname}.install
-options=('!libtool' 'strip' 'debug')
-source=("git+https://gitlab.gnome.org/GNOME/pango" "pango.install")
-sha256sums=('SKIP'
- '1e69feead9d9e5a76e7e0dc1b3da3b8938f65f58c02449478900559be50e9ac7')
-
+url="https://www.pango.org/"
+arch=(x86_64)
+license=(LGPL)
+provides=(pango)
+conflicts=(pango)
+depends=(libthai cairo libxft harfbuzz fribidi)
+makedepends=(gobject-introspection git meson)
+#checkdepends=(ttf-dejavu cantarell-fonts)
+source=("git+https://gitlab.gnome.org/GNOME/pango.git")
+sha256sums=('SKIP')
+
pkgver() {
- cd $_realname
- git describe --tags | sed 's/-/.r/' |tr - .
+ cd pango
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd pango
}
build() {
- arch-meson $_realname build -D enable_docs=true
+ arch-meson pango build -D gtk_doc=false
ninja -C build
}
+#check() {
+# meson test -C build --print-errorlogs
+#}
+
package() {
- DESTDIR=$pkgdir ninja -C build install
-# rm -r "$pkgdir"/usr/{lib,share}/installed-tests
+ DESTDIR="$pkgdir" meson install -C build
}
diff --git a/pango.install b/pango.install
deleted file mode 100644
index 55057fabd80d..000000000000
--- a/pango.install
+++ /dev/null
@@ -1,21 +0,0 @@
-# arg 1: the new package version
-post_install() {
- # we need to ldconfig first, in case xfree86's libs aren't
- # in ld.so.cache yet
- sbin/ldconfig -r .
- #usr/bin/pango-querymodules >etc/pango/pango.modules
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- if [ -f usr/etc/pango/pango.modules ]; then
- rm usr/etc/pango/pango.modules
- fi
- post_install $1
-}
-
-# arg 1: the old package version
-pre_remove() {
- rm etc/pango/pango.modules
-}