summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212022-08-04 22:44:52 +0200
committera8212022-08-04 22:44:52 +0200
commitc72d8ef8783e164724516a76a4561fcce124c394 (patch)
treec445d2bbbbd7f530a165c36634162b79b6015208
parent1ceac5b5fceb7ab70d8c87a67566bcdb326747cb (diff)
downloadaur-c72d8ef8783e164724516a76a4561fcce124c394.tar.gz
Update PKGBUILD to match official package
Create also pango-docs-git
-rw-r--r--.SRCINFO19
-rw-r--r--[-rwxr-xr-x]PKGBUILD44
2 files changed, 41 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c467b6d02404..5ca5af470ae4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,34 @@
pkgbase = pango-git
pkgdesc = A library for layout and rendering of text
- pkgver = 1.44.3
+ pkgver = 1.50.8.r7.g4b5905aa
pkgrel = 1
epoch = 1
url = https://www.pango.org/
arch = x86_64
license = LGPL
makedepends = gobject-introspection
+ makedepends = help2man
makedepends = git
makedepends = meson
- makedepends = libthai
+ makedepends = gi-docgen
depends = cairo
depends = libxft
depends = harfbuzz
depends = fribidi
depends = libthai
- optdepends = libthai: Thai language support
- provides = pango
- conflicts = pango
source = git+https://gitlab.gnome.org/GNOME/pango.git
sha256sums = SKIP
pkgname = pango-git
+ provides = pango
+ provides = libpango-1.0.so
+ provides = libpangocairo-1.0.so
+ provides = libpangoft2-1.0.so
+ provides = libpangoxft-1.0.so
+ conflicts = pango
+pkgname = pango-docs-git
+ pkgdesc = A library for layout and rendering of text (documentation)
+ depends =
+ provides = pango-docs
+ conflicts = pango-docs
diff --git a/PKGBUILD b/PKGBUILD
index 947bd44d4903..f7519e7aa0b5 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,51 @@
-# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Vincent Grande <shoober420@gmail.com>
# Contributor: Jan de Groot <jgc@archlinux.org>
-pkgname=pango-git
-pkgver=1.44.3
+pkgbase=pango-git
+pkgname=(pango-git pango-docs-git)
+pkgver=1.50.8.r7.g4b5905aa
pkgrel=1
epoch=1
pkgdesc="A library for layout and rendering of text"
url="https://www.pango.org/"
arch=(x86_64)
license=(LGPL)
-provides=(pango)
-conflicts=(pango)
depends=(cairo libxft harfbuzz fribidi libthai)
-makedepends=(gobject-introspection git meson libthai)
-optdepends=("libthai: Thai language support")
-#checkdepends=(ttf-dejavu cantarell-fonts)
+makedepends=(gobject-introspection help2man git meson gi-docgen)
source=("git+https://gitlab.gnome.org/GNOME/pango.git")
sha256sums=('SKIP')
pkgver() {
cd pango
- git describe --tags | sed 's/-/+/g'
-}
-
-prepare() {
- cd pango
+ git describe --tags | sed 's/-/.r/;s/-/./g'
}
build() {
- arch-meson pango build -D gtk_doc=false
- ninja $NINJAFLAGS -C build
+ arch-meson pango build -D gtk_doc=true
+ meson compile -C build
}
+#Not running checks according to official PKGBUILD
#check() {
# meson test -C build --print-errorlogs
#}
-package() {
- DESTDIR="$pkgdir" meson install -C build
+package_pango-git() {
+ provides=(pango libpango{,cairo,ft2,xft}-1.0.so)
+ conflicts=(pango)
+
+ meson install -C build --destdir "$pkgdir"
+
+ mkdir -p doc/usr/share
+ mv {"$pkgdir",doc}/usr/share/doc
+}
+
+package_pango-docs-git() {
+ pkgdesc+=" (documentation)"
+ provides=(pango-docs)
+ conflicts=(pango-docs)
+ depends=()
+
+ mv doc/* "$pkgdir"
}