summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2019-11-18 19:31:00 +0100
committerValHue2019-11-18 19:31:00 +0100
commit9ba2e96edd0b1c6acf3ee23f549f68c576604cf5 (patch)
treeb3a771cd90541d3c5ede0da5dd3733b3dc01730a
downloadaur-9ba2e96edd0b1c6acf3ee23f549f68c576604cf5.tar.gz
Initial Import.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f5de9c153e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pango-legacy
+ pkgdesc = A library for layout and rendering of text. This is the latest supported version without harfbuzz version error (Harfbuzz version too old (1.4.2))
+ pkgver = 1.44.1
+ pkgrel = 1
+ url = https://www.pango.org/
+ arch = x86_64
+ license = LGPL
+ depends = libthai
+ depends = cairo
+ depends = libxft
+ depends = harfbuzz
+ depends = fribidi
+ source = pango-1.44.1.tar.gz::https://archive.archlinux.org/packages/p/pango/pango-1%3A1.44.1-1-x86_64.pkg.tar.xz
+ sha256sums = ad55288cf833f77b441bb04c5b3351991ebc346a2b6aa9d7a8f07917d78f2d8c
+
+pkgname = pango-legacy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..701525a6c511
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: ValHue <vhuelamo@gmail.com>
+#
+# Contributor: ValHue <vhuelamo@gmail.com>
+#
+_pkgname="pango"
+pkgname="${_pkgname}-legacy"
+pkgver="1.44.1"
+pkgrel="1"
+pkgdesc="A library for layout and rendering of text. This is the latest supported version without harfbuzz version error (Harfbuzz version too old (1.4.2))"
+url="https://www.pango.org/"
+arch=('x86_64')
+license=(LGPL)
+depends=(libthai cairo libxft harfbuzz fribidi)
+source=(
+"${_pkgname}-${pkgver}.tar.gz::https://archive.archlinux.org/packages/p/pango/pango-1%3A1.44.1-1-x86_64.pkg.tar.xz"
+)
+sha256sums=('ad55288cf833f77b441bb04c5b3351991ebc346a2b6aa9d7a8f07917d78f2d8c')
+
+package() {
+ install -d ${pkgdir}/opt/${pkgname}
+ mv ./usr ${pkgdir}/opt/${pkgname}
+}
+
+# vim:set ts=4 sw=4 et syn=sh ft=sh: