summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-30 21:04:03 +0300
committerDimitris Kiziridis2020-04-30 21:04:03 +0300
commita7c8bc1d0483d471335af1956f1133ba9dcc6a2c (patch)
treef454add42135e8027a54e2220f2c225e9a33d61f
parent9ba2e96edd0b1c6acf3ee23f549f68c576604cf5 (diff)
downloadaur-a7c8bc1d0483d471335af1956f1133ba9dcc6a2c.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD37
2 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f5de9c153e4..84dfe7311b8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = pango-legacy
pkgdesc = A library for layout and rendering of text. This is the latest supported version without harfbuzz version error (Harfbuzz version too old (1.4.2))
pkgver = 1.44.1
- pkgrel = 1
- url = https://www.pango.org/
+ pkgrel = 2
+ url = https://pango.gnome.org
arch = x86_64
license = LGPL
depends = libthai
diff --git a/PKGBUILD b/PKGBUILD
index 701525a6c511..7ee0c9e88c9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
-# Maintainer: ValHue <vhuelamo@gmail.com>
-#
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
# Contributor: ValHue <vhuelamo@gmail.com>
-#
-_pkgname="pango"
-pkgname="${_pkgname}-legacy"
-pkgver="1.44.1"
-pkgrel="1"
-pkgdesc="A library for layout and rendering of text. This is the latest supported version without harfbuzz version error (Harfbuzz version too old (1.4.2))"
-url="https://www.pango.org/"
+
+pkgname=pango-legacy
+pkgver=1.44.1
+pkgrel=2
+pkgdesc='A library for layout and rendering of text. This is the latest supported version without harfbuzz version error (Harfbuzz version too old (1.4.2))'
+url='https://pango.gnome.org'
arch=('x86_64')
-license=(LGPL)
-depends=(libthai cairo libxft harfbuzz fribidi)
-source=(
-"${_pkgname}-${pkgver}.tar.gz::https://archive.archlinux.org/packages/p/pango/pango-1%3A1.44.1-1-x86_64.pkg.tar.xz"
-)
+license=('LGPL')
+depends=('libthai'
+ 'cairo'
+ 'libxft'
+ 'harfbuzz'
+ 'fribidi')
+source=("${pkgname%-legacy}-${pkgver}.tar.gz::https://archive.archlinux.org/packages/p/pango/pango-1%3A${pkgver}-1-x86_64.pkg.tar.xz")
sha256sums=('ad55288cf833f77b441bb04c5b3351991ebc346a2b6aa9d7a8f07917d78f2d8c')
package() {
- install -d ${pkgdir}/opt/${pkgname}
- mv ./usr ${pkgdir}/opt/${pkgname}
+ install -d "${pkgdir}/opt/${pkgname}"
+ mv ./usr "${pkgdir}/opt/${pkgname}"
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -s /usr/share/licenses/common/LGPL/license.txt "${pkgdir}/usr/share/licenses/${pkgname}"
}
-
-# vim:set ts=4 sw=4 et syn=sh ft=sh:
+# vim:set ts=4 sw=4 et syn=sh ft=sh: \ No newline at end of file