summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lamskoy2016-04-10 22:41:51 +0300
committerEugene Lamskoy2016-04-10 22:41:51 +0300
commit5c0fc5524c831aea9dcf6d65ab79995354a6ac27 (patch)
treee964fc652a6d3e0921c3792627d3d286596d6454
downloadaur-5c0fc5524c831aea9dcf6d65ab79995354a6ac27.tar.gz
initial
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD38
-rw-r--r--pango.install8
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c147371c0271
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by makepkg 5.0.1
+# Sun Apr 10 19:40:56 UTC 2016
+pkgbase = pango-ubuntu
+ pkgdesc = A library for layout and rendering of text (for compat with cairo-ubuntu, fontconfig-ubuntu)
+ pkgver = 1.40.0
+ pkgrel = 1
+ url = http://www.pango.org/
+ install = pango.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ checkdepends = ttf-dejavu
+ makedepends = harfbuzz
+ makedepends = fontconfig-ubuntu
+ makedepends = cairo-ubuntu
+ makedepends = libxft
+ makedepends = libthai
+ makedepends = gobject-introspection
+ makedepends = help2man
+ depends = libthai
+ depends = cairo-ubuntu
+ depends = libxft
+ depends = harfbuzz
+ provides = pango=$pkgver
+ conflicts = pango
+ replaces = pango
+ source = http://ftp.gnome.org/pub/GNOME/sources//pango/1.40/pango-1.40.0.tar.xz
+ sha256sums = da17985df314cb07d066ab5424f59c21ce973ece05b7de4df04d798ec8511c8b
+
+pkgname = pango-ubuntu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ec88de9ffd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+pkgname=pango-ubuntu
+_pkgbase=pango
+pkgver=1.40.0
+pkgrel=1
+pkgdesc="A library for layout and rendering of text (for compat with cairo-ubuntu, fontconfig-ubuntu)"
+arch=('i686' 'x86_64')
+license=('LGPL')
+depends=('libthai' 'cairo-ubuntu' 'libxft' 'harfbuzz')
+provides=('pango=$pkgver')
+replaces=('pango')
+conflicts=('pango')
+makedepends=('harfbuzz' 'fontconfig-ubuntu' 'cairo-ubuntu' 'libxft' 'libthai' 'gobject-introspection' 'help2man')
+checkdepends=('ttf-dejavu')
+install=pango.install
+source=(http://ftp.gnome.org/pub/GNOME/sources//${_pkgbase}/${pkgver:0:4}/${_pkgbase}-${pkgver}.tar.xz)
+url="http://www.pango.org/"
+sha256sums=('da17985df314cb07d066ab5424f59c21ce973ece05b7de4df04d798ec8511c8b')
+
+build() {
+ cd ${_pkgbase}-${pkgver}
+
+ rm -f pango-view/pango-view.1.in
+
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --with-included-modules=basic-fc
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+check() {
+ cd ${_pkgbase}-${pkgver}
+ make -k check || :
+}
+
+package() {
+ cd ${_pkgbase}-${pkgver}
+ make -j1 DESTDIR="${pkgdir}" install
+}
diff --git a/pango.install b/pango.install
new file mode 100644
index 000000000000..68f7fcdc6fe9
--- /dev/null
+++ b/pango.install
@@ -0,0 +1,8 @@
+post_upgrade() {
+ if [ -f usr/etc/pango/pango.modules ]; then
+ rm usr/etc/pango/pango.modules
+ fi
+ if [ -f etc/pango/pango.modules ]; then
+ rm etc/pango/pango.modules
+ fi
+}