summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Sutton2017-10-07 10:30:34 +0100
committerPeter Sutton2017-10-07 10:30:34 +0100
commit35b7bceaeb961ce82c644ee5f49b40df64b489b1 (patch)
tree88b93ad7a253578fd1072d198b518ec7deda452d
downloadaur-35b7bceaeb961ce82c644ee5f49b40df64b489b1.tar.gz
Initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD62
3 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c68cde54cd15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = pangolin-git
+ pkgdesc = Pangolin is a lightweight portable rapid development library for managing OpenGL display / interaction and abstracting video input.
+ pkgver = 2017.10.07
+ pkgrel = 1
+ url = https://github.com/stevenlovegrove/Pangolin
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = doxygen
+ makedepends = git
+ depends = glew
+ depends = python
+ optdepends = cuda
+ optdepends = eignen
+ optdepends = ffmpeg
+ optdepends = libdc1394
+ optdepends = libjpeg-turbo
+ optdepends = libpng
+ optdepends = libtiff
+ optdepends = libuvc
+ optdepends = openexr
+ optdepends = openni2
+ provides = pangolin
+ conflicts = pangolin
+ source = LICENSE
+ source = pangolin::git+https://github.com/stevenlovegrove/Pangolin.git
+ md5sums = 4e1a0885cb682d59abd660ae471481aa
+ md5sums = SKIP
+
+pkgname = pangolin-git
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..9b3c9002832a
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+Copyright (c) 2011 Steven Lovegrove and Richard Newcombe
+
+Permission is hereby granted, free of charge, to any person
+obtaining a copy of this software and associated documentation
+files (the "Software"), to deal in the Software without
+restriction, including without limitation the rights to use,
+copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following
+conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
+OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
+HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca36b9051908
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Peter Sutton <foxxy@foxdogstudios.com>
+pkgname=pangolin-git
+pkgver=2017.10.07
+pkgrel=1
+pkgdesc="Pangolin is a lightweight portable rapid development library for managing OpenGL display / interaction and abstracting video input."
+arch=(x86_64)
+url="https://github.com/stevenlovegrove/Pangolin"
+license=('MIT')
+groups=()
+depends=(
+ 'glew'
+ 'python'
+)
+optdepends=(
+ 'cuda'
+ 'eignen'
+ 'ffmpeg'
+ 'libdc1394'
+ 'libjpeg-turbo'
+ 'libpng'
+ 'libtiff'
+ 'libuvc'
+ 'openexr'
+ 'openni2'
+ # OpenNI/OpenNI2
+ # DepthSense SDK
+)
+makedepends=('cmake' 'doxygen' 'git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=(
+ 'LICENSE'
+ 'pangolin::git+https://github.com/stevenlovegrove/Pangolin.git'
+)
+noextract=()
+md5sums=('4e1a0885cb682d59abd660ae471481aa' 'SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_PREFIX_PATH=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ ..
+ cmake --build .
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}/build"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}