summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2020-05-04 18:51:05 -0400
committerChris Severance2020-05-04 18:51:05 -0400
commit9ac2cf80cd091ae489b5db1f7cc621d135f9c755 (patch)
treec2abcb36339096db23d7d9e37e18d53a65c8fd86
downloadaur-9ac2cf80cd091ae489b5db1f7cc621d135f9c755.tar.gz
Initial Import
-rw-r--r--.SRCINFO21
-rw-r--r--0001-Re-add-pango_x_get_shaper_map-it-is-still-used-in-th.patch39
-rw-r--r--0002-disable-shaper.patch15
-rw-r--r--PKGBUILD52
4 files changed, 127 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de9b41024c9f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = pangox-compat
+ pkgdesc = X Window System font support for Pango
+ pkgver = 0.0.2+2+gedb9e09
+ pkgrel = 3
+ url = http://www.pango.org/
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = pango
+ source = git+https://gitlab.gnome.org/Archive/pangox-compatcommit=edb9e0904d04d1da02bba7b78601a2aba05aaa47
+ source = 0001-Re-add-pango_x_get_shaper_map-it-is-still-used-in-th.patch
+ source = 0002-disable-shaper.patch
+ md5sums = SKIP
+ md5sums = e4ab908c4501116d492c7cc0b70ab305
+ md5sums = 8d78182e9747b425b223fa8a2b82d210
+ sha256sums = SKIP
+ sha256sums = d5aad903439ede05b866c9a2962f293bec4897f07d5a7b07ebc5aa99eeb27e48
+ sha256sums = 0a33987e97807211bc74a851348bcee4a0a6147d2d7f1e23c9c7912505ba27db
+
+pkgname = pangox-compat
+
diff --git a/0001-Re-add-pango_x_get_shaper_map-it-is-still-used-in-th.patch b/0001-Re-add-pango_x_get_shaper_map-it-is-still-used-in-th.patch
new file mode 100644
index 000000000000..de85c1719dd1
--- /dev/null
+++ b/0001-Re-add-pango_x_get_shaper_map-it-is-still-used-in-th.patch
@@ -0,0 +1,39 @@
+From bd0fcfbd2f8f493e96955c1edd8a791de1e6568a Mon Sep 17 00:00:00 2001
+From: Jan de Groot <jgc@archlinux.org>
+Date: Sun, 19 Feb 2017 07:57:57 +0000
+Subject: [PATCH] Re-add pango_x_get_shaper_map, it is still used in the
+ fallback code
+
+---
+ pangox.c | 15 +++++++++++++++
+ 1 file changed, 15 insertions(+)
+
+diff --git a/pangox.c b/pangox.c
+index 0a66cc9..1e6efc6 100644
+--- a/pangox.c
++++ b/pangox.c
+@@ -1344,6 +1344,21 @@ pango_x_font_describe (PangoFont *font)
+ return NULL;
+ }
+
++PangoMap *
++pango_x_get_shaper_map (PangoLanguage *language)
++{
++ static guint engine_type_id = 0;
++ static guint render_type_id = 0;
++
++ if (engine_type_id == 0)
++ {
++ engine_type_id = g_quark_from_static_string (PANGO_ENGINE_TYPE_SHAPE);
++ render_type_id = g_quark_from_static_string (PANGO_RENDER_TYPE_X);
++ }
++
++ return pango_find_map (language, engine_type_id, render_type_id);
++}
++
+ static PangoCoverage *
+ pango_x_font_get_coverage (PangoFont *font,
+ PangoLanguage *language)
+--
+2.11.1
+
diff --git a/0002-disable-shaper.patch b/0002-disable-shaper.patch
new file mode 100644
index 000000000000..87f4598e39e3
--- /dev/null
+++ b/0002-disable-shaper.patch
@@ -0,0 +1,15 @@
+--- pangox-compat/pangox.c.orig 2020-05-04 18:31:53.421197064 -0400
++++ pangox-compat/pangox.c 2020-05-04 18:32:41.251146923 -0400
+@@ -277,11 +277,11 @@ pango_x_font_class_init (PangoXFontClass
+ object_class->finalize = pango_x_font_finalize;
+ object_class->dispose = pango_x_font_dispose;
+
+ font_class->describe = pango_x_font_describe;
+ font_class->get_coverage = pango_x_font_get_coverage;
+- font_class->find_shaper = pango_x_font_find_shaper;
++ /* font_class->find_shaper = pango_x_font_find_shaper; */
+ font_class->get_glyph_extents = pango_x_font_get_glyph_extents;
+ font_class->get_metrics = pango_x_font_get_metrics;
+ font_class->get_font_map = pango_x_font_get_font_map;
+ }
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..623af14b5f3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+
+pkgname='pangox-compat'
+pkgver='0.0.2+2+gedb9e09'
+pkgrel='3'
+pkgdesc='X Window System font support for Pango'
+arch=('x86_64')
+url='http://www.pango.org/'
+license=('LGPL')
+depends=('pango')
+makedepends=('git')
+source=(
+ "git+https://gitlab.gnome.org/Archive/pangox-compat"
+ '0001-Re-add-pango_x_get_shaper_map-it-is-still-used-in-th.patch'
+ '0002-disable-shaper.patch'
+)
+source[0]+='commit=edb9e0904d04d1da02bba7b78601a2aba05aaa47' # master
+md5sums=('SKIP'
+ 'e4ab908c4501116d492c7cc0b70ab305'
+ '8d78182e9747b425b223fa8a2b82d210')
+sha256sums=('SKIP'
+ 'd5aad903439ede05b866c9a2962f293bec4897f07d5a7b07ebc5aa99eeb27e48'
+ '0a33987e97807211bc74a851348bcee4a0a6147d2d7f1e23c9c7912505ba27db')
+
+pkgver() {
+ cd ${pkgname}
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd ${pkgname}
+ patch -Nup1 -i '../0001-Re-add-pango_x_get_shaper_map-it-is-still-used-in-th.patch'
+ # diff -pNau5 pangox-compat/pangox.c{.orig,} > '0002-disable-shaper.patch'
+ patch -Nup1 -i '../0002-disable-shaper.patch'
+}
+
+build() {
+ cd ${pkgname}
+
+ if [ ! -s 'Makefile' ]; then
+ NOCONFIGURE=1 ./autogen.sh
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --disable-static
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ fi
+ make
+}
+
+package() {
+ cd ${pkgname}
+ make -j1 DESTDIR="${pkgdir}" install
+}