summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2019-06-05 22:38:20 +0200
committerChristian Hesse2019-06-05 22:38:20 +0200
commit0208f3d835306cd9f68e7828da117b75f280ff33 (patch)
tree8d2e83a8892652b13898c6021a16e36fd52ac5b8
parentb103dc0e989699d893ded6ae1e8994a125e5aa17 (diff)
downloadaur-0208f3d835306cd9f68e7828da117b75f280ff33.tar.gz
commit panini 0.73.0-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 18 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bde6a5b92437..9cd06ee5d7de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
pkgbase = panini
- pkgdesc = A portable panoramic image viewer with 3D rotation and perspective control, using OpenGL in the Qt framework
- pkgver = 0.71.104
- pkgrel = 6
- url = http://sourceforge.net/projects/pvqt/
+ pkgdesc = visual tool for creating perspective views from panoramic and wide angle photographs
+ pkgver = 0.73.0
+ pkgrel = 1
+ url = https://github.com/lazarus-pkgs/panini
arch = i686
arch = x86_64
license = GPL
- depends = qt4
+ depends = qt5-base
depends = zlib
depends = glu
- conflicts = pvqt
- replaces = pvqt
- source = http://downloads.sourceforge.net/project/pvqt/panini/Panini%200.71.100/Panini-0.71.104-src.zip
- source = panini-build.patch
- sha256sums = aacd27a71049c5e3b953afc02ecd67fb9bfd35702255ff5cc21a96719c0c82b3
- sha256sums = 609a2e6851a872ec6dce7825a415e7e549bf6ec605d6f6ee3f0853160ee62769
+ source = panini-0.73.0.tar.gz::https://github.com/lazarus-pkgs/panini/archive/v0.73.0.tar.gz
+ sha256sums = 9cdb6a40e9ea53a5b35ab3a73cf66879fe253d94908d108203b82847a08e33ed
pkgname = panini
diff --git a/PKGBUILD b/PKGBUILD
index e5245bc9f52a..c76009d0a939 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,25 @@
# Contributor: <kontakt.zuf(at)gmail.com>
pkgname=panini
-pkgver=0.71.104
-pkgrel=6
-pkgdesc='A portable panoramic image viewer with 3D rotation and perspective control, using OpenGL in the Qt framework'
-url='http://sourceforge.net/projects/pvqt/'
+pkgver=0.73.0
+pkgrel=1
+pkgdesc='visual tool for creating perspective views from panoramic and wide angle photographs'
+url='https://github.com/lazarus-pkgs/panini'
arch=('i686' 'x86_64')
-depends=('qt4' 'zlib' 'glu')
-conflicts=('pvqt')
-replaces=('pvqt')
+depends=('qt5-base' 'zlib' 'glu')
license=('GPL')
-source=("http://downloads.sourceforge.net/project/pvqt/panini/Panini%200.71.100/Panini-${pkgver}-src.zip"
- 'panini-build.patch')
-sha256sums=('aacd27a71049c5e3b953afc02ecd67fb9bfd35702255ff5cc21a96719c0c82b3'
- '609a2e6851a872ec6dce7825a415e7e549bf6ec605d6f6ee3f0853160ee62769')
-
-prepare() {
- cd "${srcdir}/Panini-${pkgver}-src"
-
- patch -p1 -i ../panini-build.patch
-}
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/lazarus-pkgs/panini/archive/v${pkgver}.tar.gz")
+sha256sums=('9cdb6a40e9ea53a5b35ab3a73cf66879fe253d94908d108203b82847a08e33ed')
build() {
- cd "${srcdir}/Panini-${pkgver}-src"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- qmake-qt4
+ qmake-qt5
make release
}
package() {
- cd "${srcdir}/Panini-${pkgver}-src"
+ cd "${srcdir}/${pkgname}-${pkgver}"
- install -D -m 0755 Panini "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m 0755 panini "${pkgdir}/usr/bin/${pkgname}"
}