summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-07-08 15:58:37 +0200
committerChristian Hesse2015-07-08 15:58:37 +0200
commit51302e5b0a4138be14eb0772eaf1f2622d599e22 (patch)
tree1cbac04e9549a3916afd4e35e6e8b83f240a0de9
downloadaur-51302e5b0a4138be14eb0772eaf1f2622d599e22.tar.gz
initial import of panini 0.71.104-5
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
-rw-r--r--panini-build.patch12
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40e3effcb1c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = panini
+ pkgdesc = A portable panoramic image viewer with 3D rotation and perspective control, using OpenGL in the Qt framework
+ pkgver = 0.71.104
+ pkgrel = 5
+ url = http://sourceforge.net/projects/pvqt/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt4
+ depends = zlib
+ depends = glu
+ conflicts = pvqt
+ replaces = pvqt
+ source = http://downloads.sourceforge.net/project/pvqt/panini/Panini%200.71.100/Panini-0.71.104-src.zip
+ source = panini-build.patch
+ md5sums = 217fd8445088c5ffd24ccd5cb8d575df
+ md5sums = 9da749019fe27695636cebbd4cbc3425
+
+pkgname = panini
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b0d4f8189ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Christian Hesse <arch@eworm.de>
+# Contributor: <kontakt.zuf(at)gmail.com>
+
+pkgname=panini
+pkgver=0.71.104
+pkgrel=5
+pkgdesc='A portable panoramic image viewer with 3D rotation and perspective control, using OpenGL in the Qt framework'
+url='http://sourceforge.net/projects/pvqt/'
+depends=('qt4' 'zlib' 'glu')
+conflicts=('pvqt')
+arch=('i686' 'x86_64')
+replaces=('pvqt')
+source=("http://downloads.sourceforge.net/project/pvqt/panini/Panini%200.71.100/Panini-${pkgver}-src.zip"
+ 'panini-build.patch')
+license=('GPL')
+md5sums=('217fd8445088c5ffd24ccd5cb8d575df'
+ '9da749019fe27695636cebbd4cbc3425')
+
+prepare() {
+ cd "${srcdir}/Panini-${pkgver}-src"
+
+ patch -p1 -i ../panini-build.patch
+}
+
+build() {
+ cd "${srcdir}/Panini-${pkgver}-src"
+
+ qmake-qt4
+ make release
+}
+
+package() {
+ cd "${srcdir}/Panini-${pkgver}-src"
+
+ install -D -m 0755 Panini "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/panini-build.patch b/panini-build.patch
new file mode 100644
index 000000000000..c6ccd330bd13
--- /dev/null
+++ b/panini-build.patch
@@ -0,0 +1,12 @@
+diff -aur Panini-0.71.104-src.old/panini.pro Panini-0.71.104-src.new/panini.pro
+--- Panini-0.71.104-src.old/panini.pro 2009-06-25 12:13:24.000000000 +0400
++++ Panini-0.71.104-src.new/panini.pro 2012-06-14 23:26:00.000000000 +0400
+@@ -4,6 +4,8 @@
+ CONFIG += debug_and_release
+ QT = gui core opengl
+
++LIBS += -lGLU -lz
++
+ # # Directories ##
+ OBJECTS_DIR = build
+ MOC_DIR = build