summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorasm0dey2018-01-28 22:31:28 +0300
committerasm0dey2018-01-28 22:38:41 +0300
commit93cbece9ce75249421fa2d048e8994238e7dad7a (patch)
tree159c446cd699b2e3e4f412f3cc3f608d025a6f1f
downloadaur-93cbece9ce75249421fa2d048e8994238e7dad7a.tar.gz
Initial
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
-rw-r--r--panotourpro4
-rw-r--r--panotourpro.desktop11
-rw-r--r--panotourpro.install11
-rw-r--r--panotourpro.pngbin0 -> 14931 bytes
6 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a5a41b4a85d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = panotourpro
+ pkgdesc = Create pro-quality virtual tours (trial version).
+ pkgver = 2.5.9
+ pkgrel = 1
+ url = http://kolor.com/
+ install = panotourpro.install
+ arch = x86_64
+ license = custom: "commercial"
+ depends = qt5-base
+ source = PanotourPro_Linux64_259_2017-12-20.tar.gz::http://download.kolor.com/ptp/stable/linux64targz
+ source = panotourpro
+ source = panotourpro.desktop
+ source = panotourpro.png
+ md5sums = 889f62c426d55b5d4313a9f1d0b234df
+ md5sums = 2fb0de89c4749a8a50c7a8fe14555d98
+ md5sums = 361fb305589d79e1047f57c8809a6a30
+ md5sums = 38a6cdebc5175c97a5cd0a8cac4b1b11
+
+pkgname = panotourpro
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb08a19ae787
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Fincer <fincer89 at hotmail dot com>
+pkgname=panotourpro
+pkgver=2.5.9
+_pkgver=259_2017-12-20
+_pkgname=PanotourPro
+pkgrel=1
+pkgdesc='Create pro-quality virtual tours (trial version).'
+arch=('x86_64')
+url='http://kolor.com/'
+license=('custom: "commercial"')
+depends=('qt5-base')
+install=$pkgname.install
+
+ source=("PanotourPro_Linux64_$_pkgver.tar.gz::http://download.kolor.com/ptp/stable/linux64targz"
+ "$pkgname" "$pkgname.desktop" "$pkgname.png")
+md5sums=('889f62c426d55b5d4313a9f1d0b234df'
+ '2fb0de89c4749a8a50c7a8fe14555d98'
+ '361fb305589d79e1047f57c8809a6a30'
+ '38a6cdebc5175c97a5cd0a8cac4b1b11')
+
+package(){
+ cd "$srcdir/$_pkgname" || return 1
+ install -dm755 $pkgdir/opt/$pkgname || return 1
+ tar -c ./ | tar -x -C $pkgdir/opt/$pkgname || return 1
+ install -Dm755 $srcdir/$pkgname $pkgdir/usr/bin/$pkgname || return 1
+ install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "$srcdir/$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+}
+
diff --git a/panotourpro b/panotourpro
new file mode 100644
index 000000000000..5807534d7496
--- /dev/null
+++ b/panotourpro
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd /opt/panotourpro
+./PanotourPro.sh $@
diff --git a/panotourpro.desktop b/panotourpro.desktop
new file mode 100644
index 000000000000..54206f2d4535
--- /dev/null
+++ b/panotourpro.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Kolor Panotour Pro
+Comment=Create pro-quality virtual tours
+Exec=panotourpro
+Icon=/usr/share/pixmaps/panotourpro.png
+Terminal=false
+Type=Application
+Categories=Application;Graphics;
+StartupNotify=true
+Name[en_US]=Kolor Panotour Pro
diff --git a/panotourpro.install b/panotourpro.install
new file mode 100644
index 000000000000..80312d4a6041
--- /dev/null
+++ b/panotourpro.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ update-desktop-database -q
+}
+
+post_remove() {
+ update-desktop-database -q
+}
diff --git a/panotourpro.png b/panotourpro.png
new file mode 100644
index 000000000000..8c8bfb01722c
--- /dev/null
+++ b/panotourpro.png
Binary files differ