summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilk Brewster2019-04-10 07:44:40 +0100
committerMilk Brewster2019-04-10 07:44:40 +0100
commitbb78b356e82f3b91fc62406a80cd169191ed6dec (patch)
treeabd3eb249d714b5a57766a53b75c625549b39a22
downloadaur-bb78b356e82f3b91fc62406a80cd169191ed6dec.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..676c2c448888
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = panrun
+ pkgdesc = Script that looks at the YAML metadata in a markdown file and runs pandoc for you.
+ pkgver = r14.2e08db5
+ pkgrel = 1
+ url = https://github.com/mb21/panrun
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = ruby
+ depends = pandoc
+ source = git+https://github.com/mb21/panrun
+ md5sums = SKIP
+
+pkgname = panrun
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec66c86768d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=panrun
+pkgver=r14.2e08db5
+pkgrel=1
+pkgdesc='Script that looks at the YAML metadata in a markdown file and runs pandoc for you.'
+arch=('i686' 'x86_64')
+url='https://github.com/mb21/panrun'
+license=('MIT')
+depends=('ruby' 'pandoc')
+makedepends=('git')
+source=('git+https://github.com/mb21/panrun')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$pkgname"
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm777 panrun "$pkgdir/usr/bin/panrun"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}