summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilk Brewster2020-08-03 17:27:48 +0100
committerMilk Brewster2020-08-03 17:27:48 +0100
commit2e47bd095b28888c872e34a6989cd3442a735f2d (patch)
tree6a160300070089355f826b8473a507e170320877
downloadaur-panrun-git.tar.gz
mv from panrun
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1231a11d1490
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = panrun-git
+ pkgdesc = Script that looks at the YAML metadata in a markdown file and runs pandoc for you.
+ pkgver = r14.2e08db5
+ pkgrel = 1
+ url = https://github.com/mb21/panrun
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = ruby
+ depends = pandoc
+ source = git+https://github.com/mb21/panrun
+ md5sums = SKIP
+
+pkgname = panrun-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..697e070148ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=panrun-git
+pkgver=r14.2e08db5
+pkgrel=1
+pkgdesc='Script that looks at the YAML metadata in a markdown file and runs pandoc for you.'
+arch=('i686' 'x86_64')
+url='https://github.com/mb21/panrun'
+license=('MIT')
+depends=('ruby' 'pandoc')
+makedepends=('git')
+source=('git+https://github.com/mb21/panrun')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$pkgname"
+ install -D -m775 panrun "$pkgdir/usr/bin/panrun"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}