summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMidov2019-09-26 11:49:39 +0200
committerMidov2019-09-26 11:49:39 +0200
commit7b53f2789b6a9428b27194eeccfe78d9705b5044 (patch)
treec3aa57e1a29cd1374f1e22121dbb9db8fc8a9ef6
parent31746e2102e92f33201f97cc64e97901a19e22c2 (diff)
parent306df8a4caa81acffc3c35022fe35032d773165d (diff)
downloadaur-7b53f2789b6a9428b27194eeccfe78d9705b5044.tar.gz
Merge branch 'master' of ssh://aur.archlinux.org/pantalaimon
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--pantalaimon.service12
3 files changed, 28 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 499bcad536df..894820cd9dbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pantalaimon
pkgdesc = Pantalaimon is an end-to-end encryption aware Matrix reverse proxy daemon.
pkgver = 0.2
- pkgrel = 2
+ pkgrel = 4
url = https://github.com/matrix-org/pantalaimon
arch = any
license = Apache
@@ -20,7 +20,15 @@ pkgbase = pantalaimon
depends = python-h11
depends = python-pydbus
depends = python-notify2
+ depends = python-olm
+ depends = python-jsonschema
+ depends = python-atomicwrites
+ depends = python-click
+ depends = python-keyring
+ depends = python-future
source = https://github.com/matrix-org/pantalaimon/archive/0.2.tar.gz
+ source = pantalaimon.service
sha256sums = 30eb448eacf6c02078bd3c58513bc426ec09fa9930833e711270eaa8abc13756
+ sha256sums = cf693e0324a7f2965bc9e64ab2c3d75137e7993503ddb3ae3dddc84af6c0b0e9
pkgname = pantalaimon
diff --git a/PKGBUILD b/PKGBUILD
index c70d28a4b4ab..bc0a69bccf9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,16 @@
pkgname=pantalaimon
pkgver=0.2
-pkgrel=2
+pkgrel=4
pkgdesc='Pantalaimon is an end-to-end encryption aware Matrix reverse proxy daemon.'
arch=('any')
url='https://github.com/matrix-org/pantalaimon'
license=('Apache')
-depends=('python' 'libolm' 'python-nio' 'python-prompt_toolkit' 'python-janus' 'python-peewee' 'python-logbook' 'python-aiohttp' 'python-cachetools' 'python-pycryptodome' 'python-unpaddedbase64' 'python-h2' 'python-h11' 'python-notify2' 'python-pydbus')
-source=("https://github.com/matrix-org/pantalaimon/archive/${pkgver}.tar.gz")
-sha256sums=('30eb448eacf6c02078bd3c58513bc426ec09fa9930833e711270eaa8abc13756')
+depends=('python' 'libolm' 'python-nio' 'python-prompt_toolkit' 'python-janus' 'python-peewee' 'python-logbook' 'python-aiohttp' 'python-cachetools' 'python-pycryptodome' 'python-unpaddedbase64' 'python-h2' 'python-h11' 'python-notify2' 'python-pydbus' 'python-olm' 'python-jsonschema' 'python-atomicwrites' 'python-click' 'python-keyring' 'python-future')
+source=("https://github.com/matrix-org/pantalaimon/archive/${pkgver}.tar.gz"
+ "${pkgname}.service")
+sha256sums=('30eb448eacf6c02078bd3c58513bc426ec09fa9930833e711270eaa8abc13756'
+ 'cf693e0324a7f2965bc9e64ab2c3d75137e7993503ddb3ae3dddc84af6c0b0e9')
build() {
cd "${pkgname}-${pkgver}"
@@ -18,5 +20,6 @@ build() {
package() {
cd "${pkgname}-${pkgver}"
python setup.py install --prefix=/usr --root="$pkgdir"
+ install -D -m 644 "${srcdir}/pantalaimon.service" ${pkgdir}/usr/lib/systemd/user/pantalaimon.service
}
diff --git a/pantalaimon.service b/pantalaimon.service
new file mode 100644
index 000000000000..668d2dc6cbe5
--- /dev/null
+++ b/pantalaimon.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=pantalaimon daemon
+After=network.target
+
+[Service]
+Restart=on-failure
+RestartSec=3
+ExecStart=/usr/bin/pantalaimon
+
+[Install]
+WantedBy=default.target
+