summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorA Frederick Christensen2022-02-02 22:16:38 -0600
committerA Frederick Christensen2022-02-02 22:16:38 -0600
commiteb290cf4a21995fca6ad854a0b60452242b651bc (patch)
treeb6ee74911d398c626f7fe53d9763bbbe93143c25
downloadaur-eb290cf4a21995fca6ad854a0b60452242b651bc.tar.gz
Initial commit
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD40
-rw-r--r--pantalaimon.service12
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c418772c1454
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = pantalaimon-git
+ pkgdesc = Pantalaimon is an end-to-end encryption aware Matrix reverse proxy daemon.
+ pkgver = e62cfe0
+ pkgrel = 1
+ url = https://github.com/matrix-org/pantalaimon
+ arch = x86_64
+ license = Apache
+ depends = python
+ depends = libolm
+ depends = python-matrix-nio
+ depends = python-prompt_toolkit
+ depends = python-janus
+ depends = python-peewee
+ depends = python-logbook
+ depends = python-aiohttp
+ depends = python-cachetools
+ depends = python-pycryptodome
+ depends = python-unpaddedbase64
+ depends = python-h2
+ depends = python-h11
+ depends = python-notify2
+ depends = python-pydbus
+ depends = python-olm
+ depends = python-jsonschema
+ depends = python-atomicwrites
+ depends = python-click
+ depends = python-appdirs
+ depends = python-keyring>=21.2.1
+ depends = python-future
+ provides = pantalaimon
+ conflicts = pantalaimon
+ source = pantalaimon::git://github.com/matrix-org/pantalaimon
+ source = pantalaimon.service
+ sha256sums = SKIP
+ sha256sums = cf693e0324a7f2965bc9e64ab2c3d75137e7993503ddb3ae3dddc84af6c0b0e9
+
+pkgname = pantalaimon-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13b1e879cfdd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: A Christensen <fauxmight@ivories.org>
+# Contributor: Midov <midov@midov.pl>
+
+_pkgname=pantalaimon
+pkgname="${_pkgname}"-git
+pkgver=e62cfe0
+pkgrel=1
+pkgdesc="Pantalaimon is an end-to-end encryption aware Matrix reverse proxy daemon."
+arch=('x86_64')
+url="https://github.com/matrix-org/pantalaimon"
+license=('Apache')
+depends=('python' 'libolm' 'python-matrix-nio' 'python-prompt_toolkit' 'python-janus' 'python-peewee' 'python-logbook' 'python-aiohttp' 'python-cachetools' 'python-pycryptodome' 'python-unpaddedbase64' 'python-h2' 'python-h11' 'python-notify2' 'python-pydbus' 'python-olm' 'python-jsonschema' 'python-atomicwrites' 'python-click' 'python-appdirs' 'python-keyring>=21.2.1' 'python-future')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("${_pkgname}::git://github.com/matrix-org/pantalaimon"
+ "${_pkgname}.service")
+sha256sums=('SKIP'
+ 'cf693e0324a7f2965bc9e64ab2c3d75137e7993503ddb3ae3dddc84af6c0b0e9')
+
+pkgber() {
+ cd "${_pkgname}"
+ git describe --always | sed -e 's|-|.|g' -e 's|v||'
+}
+
+build() {
+ cd "${_pkgname}"
+}
+
+package() {
+ cd "${_pkgname}"
+ python setup.py install --prefix=/usr --root="$pkgdir"
+ install -Dm644 "${srcdir}"/pantalaimon.service "${pkgdir}"/usr/lib/systemd/user/pantalaimon.service
+ install -Dm644 "${srcdir}"/"${_pkgname}"/docs/man/*.md -t "${pkgdir}"/usr/share/doc/"${_pkgname}"/
+ install -Dm644 "${srcdir}"/"${_pkgname}"/docs/man/*.1 -t "${pkgdir}"/usr/share/man/man1/
+ install -Dm644 "${srcdir}"/"${_pkgname}"/docs/man/*.5 -t "${pkgdir}"/usr/share/man/man5/
+ install -Dm644 "${srcdir}"/"${_pkgname}"/docs/man/*.8 -t "${pkgdir}"/usr/share/man/man8/
+ install -Dm644 "${srcdir}"/"${_pkgname}"/LICENSE -t "${pkgdir}"/usr/share/licenses/"${_pkgname}"/
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/pantalaimon.service b/pantalaimon.service
new file mode 100644
index 000000000000..668d2dc6cbe5
--- /dev/null
+++ b/pantalaimon.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=pantalaimon daemon
+After=network.target
+
+[Service]
+Restart=on-failure
+RestartSec=3
+ExecStart=/usr/bin/pantalaimon
+
+[Install]
+WantedBy=default.target
+