summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-09 12:04:47 +0200
committerMaxime Gauduin2015-06-09 12:04:47 +0200
commit9c4ccf5c3e916647106a588a0e7d09c593660a1f (patch)
treef1942bfc01821b8a9329e356ba5847e622c58a08
downloadaur-9c4ccf5c3e916647106a588a0e7d09c593660a1f.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--MKPKG6
-rw-r--r--PKGBUILD45
-rw-r--r--pantheon-calculator.install13
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0eba6eddd8b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = pantheon-calculator-bzr
+ pkgdesc = The Pantheon Calculator
+ pkgver = r132
+ pkgrel = 1
+ url = https://launchpad.net/pantheon-calculator
+ install = pantheon-calculator.install
+ arch = i686
+ arch = x86_64
+ groups = pantheon-unstable
+ license = GPL3
+ makedepends = bzr
+ makedepends = cmake
+ makedepends = vala
+ depends = granite-bzr
+ provides = pantheon-calculator
+ conflicts = pantheon-calculator
+ source = bzr+lp:pantheon-calculator
+ sha256sums = SKIP
+
+pkgname = pantheon-calculator-bzr
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..5edef179307c
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,6 @@
+pkgname=('pantheon-calculator-bzr')
+builddeps=('granite-bzr')
+
+check_bzr $packagedir/$pkgname/${pkgname%-*}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3f83f60fa21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=pantheon-calculator-bzr
+pkgver=r132
+pkgrel=1
+pkgdesc='The Pantheon Calculator'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/pantheon-calculator'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('granite-bzr')
+makedepends=('bzr' 'cmake' 'vala')
+provides=('pantheon-calculator')
+conflicts=('pantheon-calculator')
+install='pantheon-calculator.install'
+source=('bzr+lp:pantheon-calculator')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd pantheon-calculator
+
+ echo "r$(bzr revno)"
+}
+
+build() {
+ cd pantheon-calculator
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ make
+}
+
+package() {
+ cd pantheon-calculator/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/pantheon-calculator.install b/pantheon-calculator.install
new file mode 100644
index 000000000000..511a2a0c7807
--- /dev/null
+++ b/pantheon-calculator.install
@@ -0,0 +1,13 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: