summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2020-05-23 22:28:21 -0400
committerSolomon Choina2020-05-23 22:28:21 -0400
commit7a7ae8d6f30eeba4f6bd4b67adab6b79b15dfa7a (patch)
tree1d0e68e5ed5972992b7a13962cee9d6fe52e3ef4
downloadaur-7a7ae8d6f30eeba4f6bd4b67adab6b79b15dfa7a.tar.gz
initial updated version
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD31
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb9da7212341
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = pantheon-dock-git
+ pkgdesc = The Pantheon Dock
+ pkgver = r1966.ac87d90
+ pkgrel = 1
+ url = https://github.com/elementary/dock
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = gnome-common
+ makedepends = meson
+ makedepends = vala
+ makedepends = gnome-menus
+ makedepends = libdbusmenu-gtk3
+ depends = libgee
+ depends = bamf
+ depends = plank
+ depends = python
+ provides = plank
+ conflicts = plank
+ source = pantheon-dock::git+https://github.com/elementary/dock
+ sha256sums = SKIP
+
+pkgname = pantheon-dock-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8045832bb85f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer <shlomochoina@gmail.com>
+
+pkgname=pantheon-dock-git
+pkgver=r1966.ac87d90
+pkgrel=1
+pkgdesc='The Pantheon Dock'
+arch=('i686' 'x86_64')
+url='https://github.com/elementary/dock'
+license=('GPL3')
+depends=('libgee' 'bamf' 'plank' 'python')
+makedepends=('git' 'gnome-common' 'meson' 'vala' 'gnome-menus' 'libdbusmenu-gtk3')
+conflicts=('plank')
+provides=('plank')
+source=(pantheon-dock::git+$url)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd pantheon-dock
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ arch-meson pantheon-dock build -Dapport=false -Denable-dbusmenu=yes -Denable-barriers=yes
+ ninja -C build
+}
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+}
+
+# vim: ts=2 sw=2 et: