summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2019-03-04 10:55:50 +0100
committerMaxime Gauduin2019-03-04 10:55:50 +0100
commit230570a366274a4a4ec1d73d189c9b385b1ffb98 (patch)
treeb7a863ba50f493f832145c9a4481fb96e76e8a98
parent8e8a9c90c52bcbef634d063dd113764facb0656a (diff)
downloadaur-230570a366274a4a4ec1d73d189c9b385b1ffb98.tar.gz
update pantheon-files-git
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD79
2 files changed, 49 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b59c85e416d..231e8cbadc76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,41 +1,36 @@
# Generated by mksrcinfo v8
-# Tue Dec 12 19:59:12 UTC 2017
+# Mon Mar 4 09:55:50 UTC 2019
pkgbase = pantheon-files-git
- pkgdesc = The Pantheon File Manager
- pkgver = r5456.d791bddb
+ pkgdesc = The Pantheon File Browser
+ pkgver = r6405.3556bde8
pkgrel = 1
url = https://github.com/elementary/files
- install = pantheon-files.install
- arch = i686
arch = x86_64
groups = pantheon-unstable
license = GPL3
makedepends = git
- makedepends = cmake
makedepends = gnome-common
makedepends = granite-git
+ makedepends = meson
makedepends = vala
depends = atk
depends = cairo
- depends = dbus-glib
- depends = desktop-file-utils
depends = gdk-pixbuf2
depends = glib2
- depends = glibc
depends = gtk3
depends = libcanberra
depends = libgee
+ depends = libgranite.so
depends = libnotify
depends = pango
- depends = plank
depends = sqlite
depends = zeitgeist
- depends = libgranite.so
optdepends = contractor-git: Various context menu entries
+ optdepends = gvfs: Cleaner devices section
optdepends = tumbler: Thumbnails generation
provides = pantheon-files
conflicts = pantheon-files
- source = git+https://github.com/elementary/files
+ source = pantheon-files::git+https://github.com/elementary/files.git
sha256sums = SKIP
pkgname = pantheon-files-git
diff --git a/PKGBUILD b/PKGBUILD
index be1c3bad8475..88ed5ed678f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,53 +2,58 @@
# Contributor: Ner0 <darkelfdarkelf666@yahoo.co.uk>
pkgname=pantheon-files-git
-pkgver=r5456.d791bddb
+pkgver=r6405.3556bde8
pkgrel=1
-pkgdesc='The Pantheon File Manager'
-arch=('i686' 'x86_64')
-url='https://github.com/elementary/files'
-license=('GPL3')
-groups=('pantheon-unstable')
-depends=('atk' 'cairo' 'dbus-glib' 'desktop-file-utils' 'gdk-pixbuf2' 'glib2'
- 'glibc' 'gtk3' 'libcanberra' 'libgee' 'libnotify' 'pango' 'plank'
- 'sqlite' 'zeitgeist'
- 'libgranite.so')
-makedepends=('git' 'cmake' 'gnome-common' 'granite-git' 'vala')
-optdepends=('contractor-git: Various context menu entries'
- 'tumbler: Thumbnails generation')
-provides=('pantheon-files')
-conflicts=('pantheon-files')
-install='pantheon-files.install'
-source=('git+https://github.com/elementary/files')
-sha256sums=('SKIP')
+pkgdesc='The Pantheon File Browser'
+arch=(x86_64)
+url=https://github.com/elementary/files
+license=(GPL3)
+groups=(pantheon-unstable)
+depends=(
+ atk
+ cairo
+ gdk-pixbuf2
+ glib2
+ gtk3
+ libcanberra
+ libgee
+ libgranite.so
+ libnotify
+ pango
+ sqlite
+ zeitgeist
+)
+makedepends=(
+ git
+ gnome-common
+ granite-git
+ meson
+ vala
+)
+optdepends=(
+ 'contractor-git: Various context menu entries'
+ 'gvfs: Cleaner devices section'
+ 'tumbler: Thumbnails generation'
+)
+provides=(pantheon-files)
+conflicts=(pantheon-files)
+source=(pantheon-files::git+https://github.com/elementary/files.git)
+sha256sums=(SKIP)
pkgver() {
- cd files
+ cd pantheon-files
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/files"
-
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build && cd build
-
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
- -DCMAKE_SKIP_RPATH='TRUE' \
- -DGSETTINGS_COMPILE='FALSE'
- make
+ arch-meson pantheon-files build \
+ -D with-unity=false
+ ninja -C build
}
package() {
- cd "$srcdir/files/build"
-
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja -C build install
}
# vim: ts=2 sw=2 et: