summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-09 12:05:20 +0200
committerMaxime Gauduin2015-06-09 12:05:20 +0200
commitc7c23939fe76f28a29c6e1befa7ecbcb81ae0c88 (patch)
tree8f6576a3f160757c8ff344b9907980944e166788
downloadaur-c7c23939fe76f28a29c6e1befa7ecbcb81ae0c88.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--MKPKG6
-rw-r--r--PKGBUILD44
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5c5a6910baa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pantheon-files-plugin-dropbox-bzr
+ pkgdesc = Dropbox integration for pantheon-files
+ pkgver = r22
+ pkgrel = 1
+ url = https://launchpad.net/pantheon-files
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = bzr
+ makedepends = cmake
+ depends = pantheon-files
+ provides = pantheon-files-plugin-dropbox
+ conflicts = pantheon-files-plugin-dropbox
+ source = bzr+lp:~elementary-apps/pantheon-files/pantheon-files-plugin-dropbox
+ sha256sums = SKIP
+
+pkgname = pantheon-files-plugin-dropbox-bzr
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..dc99577a60cd
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,6 @@
+pkgname=('pantheon-files-plugin-dropbox-bzr')
+builddeps=('pantheon-files-bzr')
+
+check_bzr $packagedir/$pkgname/${pkgname%-*}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f7ff4dbb6cf6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Ner0 <darkelfdarkelf666@yahoo.co.uk>
+
+pkgname=pantheon-files-plugin-dropbox-bzr
+pkgver=r22
+pkgrel=1
+pkgdesc='Dropbox integration for pantheon-files'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/pantheon-files'
+license=('GPL3')
+depends=('pantheon-files')
+makedepends=('bzr' 'cmake')
+provides=('pantheon-files-plugin-dropbox')
+conflicts=('pantheon-files-plugin-dropbox')
+source=('bzr+lp:~elementary-apps/pantheon-files/pantheon-files-plugin-dropbox')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-*}
+
+ echo "r$(bzr revno)"
+}
+
+build() {
+ cd pantheon-files-plugin-dropbox
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ make
+}
+
+package() {
+ cd pantheon-files-plugin-dropbox/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: