summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-05-30 23:37:00 +0200
committerMaxime Gauduin2017-05-30 23:37:00 +0200
commit75af07ae0a10ac63add6f3a90c4411c7baec7c87 (patch)
treed9553c56f199ca056b7a51745bb1c08c045d3206
downloadaur-75af07ae0a10ac63add6f3a90c4411c7baec7c87.tar.gz
Add pantheon-geoclue2-agent-git
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD48
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0d15f5e08a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Tue May 30 21:37:00 UTC 2017
+pkgbase = pantheon-geoclue2-agent-git
+ pkgdesc = Pantheon Geoclue2 Agent
+ pkgver = r78.3546705
+ pkgrel = 1
+ url = https://github.com/elementary/pantheon-agent-geoclue2
+ arch = i686
+ arch = x86_64
+ groups = pantheon-unstable
+ license = GPL3
+ makedepends = cmake
+ makedepends = cmake-modules-elementary-git
+ makedepends = git
+ makedepends = intltool
+ makedepends = vala
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = geoclue2
+ provides = pantheon-geoclue2-agent
+ conflicts = pantheon-geoclue2-agent
+ source = pantheon-geoclue2-agent::git+https://github.com/elementary/pantheon-agent-geoclue2.git
+ sha256sums = SKIP
+
+pkgname = pantheon-geoclue2-agent-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..516d594f0670
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=pantheon-geoclue2-agent-git
+pkgver=r78.3546705
+pkgrel=1
+pkgdesc='Pantheon Geoclue2 Agent'
+arch=('i686' 'x86_64')
+url='https://github.com/elementary/pantheon-agent-geoclue2'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('glib2' 'glibc' 'gtk3' 'geoclue2')
+makedepends=('cmake' 'cmake-modules-elementary-git' 'git' 'intltool' 'vala')
+provides=('pantheon-geoclue2-agent')
+conflicts=('pantheon-geoclue2-agent')
+source=('pantheon-geoclue2-agent::git+https://github.com/elementary/pantheon-agent-geoclue2.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd pantheon-geoclue2-agent
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd pantheon-geoclue2-agent
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd pantheon-geoclue2-agent/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ make
+}
+
+package() {
+ cd pantheon-geoclue2-agent/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: