summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRiley Trautman2016-02-21 15:29:38 -0600
committerRiley Trautman2016-02-21 15:29:38 -0600
commit93ce8f77e6b1885fcca6c692c017394d5f56162a (patch)
tree5ed24da766ec4cf84e216e03019f6e2f43537cf9
downloadaur-93ce8f77e6b1885fcca6c692c017394d5f56162a.tar.gz
Initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD58
-rw-r--r--pantheon-mail.install14
3 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1864932a97d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by mksrcinfo v8
+# Sun Feb 21 21:26:31 UTC 2016
+pkgbase = pantheon-mail-bzr
+ pkgdesc = The Pantheon mail client
+ pkgver = r1978
+ pkgrel = 1
+ url = https://launchpad.net/pantheon-mail
+ install = pantheon-mail.install
+ arch = i686
+ arch = x86_64
+ groups = pantheon-unstable
+ license = LGPL2.1
+ makedepends = bzr
+ makedepends = cmake
+ makedepends = gobject-introspection
+ makedepends = vala
+ makedepends = vte3
+ makedepends = webkitgtk
+ depends = desktop-file-utils
+ depends = granite-bzr
+ depends = gtksourceview3
+ depends = libpeas
+ depends = zeitgeist
+ optdepends = webkitgtk: Browser Preview extension
+ provides = pantheon-mail
+ conflicts = pantheon-mail
+ source = pantheon-mail::bzr+lp:pantheon-mail
+ sha256sums = SKIP
+
+pkgname = pantheon-mail-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b4bd5aea5bfc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Riley Trautman <asonix@tamu.edu>
+
+_pkgname=pantheon-mail
+pkgname=$_pkgname-bzr
+pkgver=r1978
+pkgrel=1
+pkgdesc='The Pantheon mail client'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/pantheon-mail'
+license=('LGPL2.1')
+groups=('pantheon-unstable')
+depends=('desktop-file-utils' 'granite-bzr' 'gtksourceview3' 'libpeas'
+ 'zeitgeist')
+makedepends=('bzr' 'cmake' 'gobject-introspection' 'vala' 'vte3' 'webkitgtk')
+optdepends=('webkitgtk: Browser Preview extension')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+install="$_pkgname.install"
+source=('pantheon-mail::bzr+lp:pantheon-mail')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+
+ echo "r$(bzr revno)"
+}
+
+prepare() {
+ cd $_pkgname
+
+ sed -i 's/gtkspell-3.0/gtkspell3-3.0/' CMakeLists.txt
+}
+
+build() {
+ cd $_pkgname
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+
+ mkdir build && cd build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
+ -DSETTINGS_COMPILE='OFF'
+ make
+}
+
+package() {
+ cd $_pkgname/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et:
+
diff --git a/pantheon-mail.install b/pantheon-mail.install
new file mode 100644
index 000000000000..088d4ccc401f
--- /dev/null
+++ b/pantheon-mail.install
@@ -0,0 +1,14 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: