summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-05-01 16:21:07 +0200
committerMaxime Gauduin2017-05-01 16:21:07 +0200
commit4f0c143912e41a81ff165badcd278dfd778acee5 (patch)
tree1da01b758e76504e1ff14b5109e7326e0f23e5c8
downloadaur-4f0c143912e41a81ff165badcd278dfd778acee5.tar.gz
Add pantheon-mail-git
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD56
2 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d28e605ff866
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+# Generated by mksrcinfo v8
+# Mon May 1 14:21:07 UTC 2017
+pkgbase = pantheon-mail-git
+ pkgdesc = The Pantheon Mail Client
+ pkgver = r2876.e1bb88dc
+ pkgrel = 1
+ url = https://github.com/elementary/mail
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ makedepends = gnome-doc-utils
+ makedepends = gobject-introspection
+ makedepends = granite-git
+ makedepends = intltool
+ makedepends = vala
+ depends = cairo
+ depends = gcr
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gmime
+ depends = gtk3
+ depends = libaccounts-glib
+ depends = libcanberra
+ depends = libgee
+ depends = libgsignon-glib
+ depends = libsecret
+ depends = libxml2
+ depends = pango
+ depends = sqlite
+ depends = webkitgtk
+ depends = libgranite.so
+ provides = pantheon-mail
+ conflicts = pantheon-mail
+ replaces = pantheon-mail-bzr
+ source = pantheon-mail::git+https://github.com/elementary/mail.git
+ sha256sums = SKIP
+
+pkgname = pantheon-mail-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7acbdf1ef98d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Riley Trautman <asonix@tamu.edu>
+
+pkgname=pantheon-mail-git
+pkgver=r2876.e1bb88dc
+pkgrel=1
+pkgdesc='The Pantheon Mail Client'
+arch=('i686' 'x86_64')
+url='https://github.com/elementary/mail'
+license=('GPL3')
+depends=('cairo' 'gcr' 'gdk-pixbuf2' 'glib2' 'glibc' 'gmime' 'gtk3'
+ 'libaccounts-glib' 'libcanberra' 'libgee' 'libgsignon-glib'
+ 'libsecret' 'libxml2' 'pango' 'sqlite' 'webkitgtk'
+ 'libgranite.so')
+makedepends=('cmake' 'git' 'gnome-doc-utils' 'gobject-introspection'
+ 'granite-git' 'intltool' 'vala')
+provides=('pantheon-mail')
+conflicts=('pantheon-mail')
+replaces=('pantheon-mail-bzr')
+source=('pantheon-mail::git+https://github.com/elementary/mail.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd pantheon-mail
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd pantheon-mail
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd pantheon-mail/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DDESKTOP_UPDATE='FALSE' \
+ -DGSETTINGS_COMPILE='FALSE' \
+ -DGSETTINGS_COMPILE_IN_PLACE='FALSE'
+ make
+}
+
+package() {
+ cd pantheon-mail/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: