summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2018-02-13 23:36:59 +0100
committerMaxime Gauduin2018-02-13 23:36:59 +0100
commit19af507ef2398c09d989c8c2ebf35264f84040de (patch)
treefd35f48c48e3c4a43e1a9c7e51ee7e00f4c65ea9
parent4bc6edac0cd8b286dfaa5aeffec6d42a343b7d1e (diff)
downloadaur-19af507ef2398c09d989c8c2ebf35264f84040de.tar.gz
pantheon-music-git: Switch to meson
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD28
2 files changed, 13 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9a694675a9c..f1cddf1f2939 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Mon May 1 14:35:00 UTC 2017
+# Tue Feb 13 22:34:14 UTC 2018
pkgbase = pantheon-music-git
pkgdesc = The Pantheon Music Player
- pkgver = r2949.5385ace5
+ pkgver = r3342.f2e6c45e
pkgrel = 1
url = https://github.com/elementary/music
- arch = i686
arch = x86_64
license = GPL3
- makedepends = cmake
+ makedepends = appstream
makedepends = git
makedepends = gobject-introspection
makedepends = granite-git
makedepends = intltool
+ makedepends = meson
makedepends = vala
depends = cairo
depends = gdk-pixbuf2
@@ -39,10 +39,7 @@ pkgbase = pantheon-music-git
optdepends = gst-plugins-ugly: "Ugly" plugin libraries
optdepends = gst-libav: Libav plugin
provides = pantheon-music
- conflicts = noise
- conflicts = noise-player
conflicts = pantheon-music
- replaces = noise-player-bzr
source = pantheon-music::git+https://github.com/elementary/music.git
source = mesa-demos-conflict.patch
source = noise-install-dirs.patch
diff --git a/PKGBUILD b/PKGBUILD
index 98092dd60e21..e39060f64269 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=pantheon-music-git
-pkgver=r2949.5385ace5
+pkgver=r3342.f2e6c45e
pkgrel=1
pkgdesc='The Pantheon Music Player'
arch=('x86_64')
@@ -12,16 +12,15 @@ depends=('cairo' 'gdk-pixbuf2' 'glib2' 'glibc' 'gst-plugins-base-libs'
'libgpod' 'libgsignon-glib' 'libpeas' 'libsoup' 'pango' 'taglib'
'zeitgeist'
'libgranite.so')
-makedepends=('cmake' 'git' 'gobject-introspection' 'granite-git' 'intltool'
- 'vala')
+makedepends=('appstream' 'git' 'gobject-introspection' 'granite-git' 'intltool'
+ 'meson' 'vala')
optdepends=('gst-plugins-base: "Base" plugin libraries'
'gst-plugins-good: "Good" plugin libraries'
'gst-plugins-bad: "Bad" plugin libraries'
'gst-plugins-ugly: "Ugly" plugin libraries'
'gst-libav: Libav plugin')
provides=('pantheon-music')
-conflicts=('noise' 'noise-player' 'pantheon-music')
-replaces=('noise-player-bzr')
+conflicts=('pantheon-music')
source=('pantheon-music::git+https://github.com/elementary/music.git'
'mesa-demos-conflict.patch'
'noise-install-dirs.patch')
@@ -36,11 +35,6 @@ pkgver() {
}
prepare() {
- cd pantheon-music
-
- patch -Np1 -i ../mesa-demos-conflict.patch
- patch -Np1 -i ../noise-install-dirs.patch
-
if [[ -d build ]]; then
rm -rf build
fi
@@ -48,20 +42,16 @@ prepare() {
}
build() {
- cd pantheon-music/build
+ cd build
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_INSTALL_LIBDIR='/usr/lib' \
- -DGSETTINGS_COMPILE='FALSE'
- make -j1
+ arch-meson ../pantheon-music
+ ninja
}
package() {
- cd pantheon-music/build
+ cd build
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja install
}
# vim: ts=2 sw=2 et: