summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-05-30 23:26:14 +0200
committerMaxime Gauduin2017-05-30 23:28:12 +0200
commitb6fb318efc5b3546f7f14871845d0038f13115c9 (patch)
treec129ed5b1ab6f353a4ef2f9a80056e941627f4a3
downloadaur-b6fb318efc5b3546f7f14871845d0038f13115c9.tar.gz
Add pantheon-polkit-agent-git
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD48
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c19897d3d02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Tue May 30 21:28:02 UTC 2017
+pkgbase = pantheon-polkit-agent-git
+ pkgdesc = Pantheon Polkit Agent
+ pkgver = 0.1.4
+ pkgrel = 1
+ url = https://github.com/elementary/pantheon-agent-polkit
+ arch = i686
+ arch = x86_64
+ groups = pantheon-unstable
+ license = GPL3
+ makedepends = cmake
+ makedepends = cmake-modules-elementary-git
+ makedepends = git
+ makedepends = intltool
+ makedepends = vala
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = polkit
+ provides = pantheon-polkit-agent
+ conflicts = pantheon-polkit-agent
+ source = pantheon-polkit-agent::git+https://github.com/elementary/pantheon-agent-polkit.git
+ sha256sums = SKIP
+
+pkgname = pantheon-polkit-agent-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4297d6b30593
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=pantheon-polkit-agent-git
+pkgver=0.1.4
+pkgrel=1
+pkgdesc='Pantheon Polkit Agent'
+arch=('i686' 'x86_64')
+url='https://github.com/elementary/pantheon-agent-polkit'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('glib2' 'glibc' 'gtk3' 'polkit')
+makedepends=('cmake' 'cmake-modules-elementary-git' 'git' 'intltool' 'vala')
+provides=('pantheon-polkit-agent')
+conflicts=('pantheon-polkit-agent')
+source=('pantheon-polkit-agent::git+https://github.com/elementary/pantheon-agent-polkit.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd pantheon-polkit-agent
+
+ git describe --tags | sed 's/-/.r/; s/-g/./'
+}
+
+prepare() {
+ cd pantheon-polkit-agent
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+}
+
+build() {
+ cd pantheon-polkit-agent/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ make
+}
+
+package() {
+ cd pantheon-polkit-agent/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: