summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-09 12:05:38 +0200
committerMaxime Gauduin2015-06-09 12:05:38 +0200
commita378b5b9ba6759701c82041949639818aac7ff6b (patch)
tree689fbe9e6a1838fd33ed7dec95ef19480191ced3
downloadaur-a378b5b9ba6759701c82041949639818aac7ff6b.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--MKPKG6
-rw-r--r--PKGBUILD41
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc4dca840d4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pantheon-print-bzr
+ pkgdesc = A small utility used to print documents that allows the user to set the preferences
+ pkgver = r8
+ pkgrel = 1
+ url = https://launchpad.net/pantheon-print
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = bzr
+ makedepends = cmake
+ makedepends = vala
+ depends = contractor
+ depends = gtk3
+ provides = pantheon-print
+ conflicts = pantheon-print
+ source = bzr+lp:pantheon-print
+ sha256sums = SKIP
+
+pkgname = pantheon-print-bzr
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..84954bbfadad
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,6 @@
+pkgname=('pantheon-print-bzr')
+builddeps=('contractor-bzr')
+
+check_bzr $packagedir/$pkgname/${pkgname%-*}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a9b1da9dfa5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=pantheon-print-bzr
+pkgver=r8
+pkgrel=1
+pkgdesc='A small utility used to print documents that allows the user to set the preferences'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/pantheon-print'
+license=('GPL3')
+depends=('contractor' 'gtk3')
+makedepends=('bzr' 'cmake' 'vala')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=('bzr+lp:pantheon-print')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-*}
+
+ printf "r%s" "$(bzr revno)"
+}
+
+build() {
+ cd ${pkgname%-*}
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+
+ cmake .. -DCMAKE_INSTALL_PREFIX='/usr'
+ make
+}
+
+package() {
+ cd ${pkgname%-*}/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: