summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2017-09-24 13:51:32 +0200
committerMaxime Gauduin2017-09-24 13:51:32 +0200
commit761440ddf401c9f2e03fbb25078a01f3fdc0e247 (patch)
treef9bcaf7bde5da26138df5cbf7b590ae6fb65ec29
parentf1f5f9fcfd72950c956e4371760a7320273d9223 (diff)
downloadaur-761440ddf401c9f2e03fbb25078a01f3fdc0e247.tar.gz
pantheon-screenshot-git r543.ed4dafa-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 13 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5080cbb3da17..94fd54ffa01f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Mon May 1 13:53:55 UTC 2017
+# Sun Sep 24 11:51:32 UTC 2017
pkgbase = pantheon-screenshot-git
pkgdesc = The Pantheon Screenshot Tool
- pkgver = r420.6bdfcd1
+ pkgver = r543.ed4dafa
pkgrel = 1
url = https://github.com/elementary/screenshot-tool
arch = i686
arch = x86_64
groups = pantheon-unstable
license = GPL3
- makedepends = cmake
makedepends = git
makedepends = granite-git
makedepends = intltool
+ makedepends = meson
makedepends = vala
depends = cairo
depends = gdk-pixbuf2
diff --git a/PKGBUILD b/PKGBUILD
index 674288bad8b1..9fb119f7919b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=pantheon-screenshot-git
-pkgver=r420.6bdfcd1
+pkgver=r543.ed4dafa
pkgrel=1
pkgdesc='The Pantheon Screenshot Tool'
arch=('i686' 'x86_64')
@@ -10,7 +10,7 @@ license=('GPL3')
groups=('pantheon-unstable')
depends=('cairo' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk3' 'libcanberra'
'libgranite.so')
-makedepends=('cmake' 'git' 'granite-git' 'intltool' 'vala')
+makedepends=('git' 'granite-git' 'intltool' 'meson' 'vala')
provides=('pantheon-screenshot')
conflicts=('pantheon-screenshot')
source=("pantheon-screenshot::git+https://github.com/elementary/screenshot-tool.git")
@@ -23,8 +23,6 @@ pkgver() {
}
prepare() {
- cd pantheon-screenshot
-
if [[ -d build ]]; then
rm -rf build
fi
@@ -32,20 +30,18 @@ prepare() {
}
build() {
- cd pantheon-screenshot/build
-
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr' \
- -DGSETTINGS_COMPILE='OFF' \
- -DICON_UPDATE='OFF'
- make
+ cd build
+
+ meson ../pantheon-screenshot \
+ --buildtype='release' \
+ --prefix='/usr'
+ ninja
}
package() {
- cd pantheon-screenshot/build
+ cd build
- make DESTDIR="${pkgdir}" install
+ DESTDIR="${pkgdir}" ninja install
}
# vim: ts=2 sw=2 et: