summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbtd13372019-07-17 21:16:38 -0300
committerbtd13372019-07-17 21:16:38 -0300
commit3003078f452d6868e815d7f4540901342a651eae (patch)
treec23c66dc022700c25d0e000d851ccc34a2db2414
downloadaur-3003078f452d6868e815d7f4540901342a651eae.tar.gz
initial release
-rw-r--r--.SRCINFO92
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD93
3 files changed, 186 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4416aac3051e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,92 @@
+pkgbase = pantheon-stable
+ pkgdesc = Meta package for the complete Pantheon desktop & apps that uses stable versions
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/elementary
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ makedepends = vala>=0.40.3-1
+ depends = cerbere
+ depends = contractor
+ depends = elementary-icon-theme
+ depends = elementary-wallpapers
+ depends = epiphany-pantheon
+ depends = file-roller
+ depends = gala
+ depends = geary
+ depends = gnome-settings-daemon-elementary
+ depends = granite
+ depends = gtk-theme-elementary
+ depends = lightdm
+ depends = lightdm-pantheon-greeter
+ depends = networkmanager
+ depends = pantheon-applications-menu
+ depends = pantheon-calculator
+ depends = pantheon-calendar
+ depends = pantheon-camera
+ depends = pantheon-code
+ depends = pantheon-default-settings
+ depends = pantheon-dpms-helper
+ depends = pantheon-files
+ depends = gvfs
+ depends = pantheon-geoclue2-agent
+ depends = pantheon-music
+ depends = pantheon-photos
+ depends = pantheon-polkit-agent
+ depends = pantheon-print
+ depends = pantheon-screenshot
+ depends = pantheon-session
+ depends = pantheon-shortcut-overlay
+ depends = pantheon-terminal
+ depends = pantheon-videos
+ depends = plank
+ depends = sound-theme-elementary-git
+ depends = switchboard
+ depends = switchboard-plug-a11y
+ depends = switchboard-plug-about
+ depends = switchboard-plug-bluetooth
+ depends = switchboard-plug-datetime
+ depends = switchboard-plug-desktop
+ depends = switchboard-plug-display
+ depends = switchboard-plug-elementary-tweaks
+ depends = switchboard-plug-applications
+ depends = switchboard-plug-keyboard
+ depends = switchboard-plug-locale
+ depends = switchboard-plug-mouse-touchpad
+ depends = switchboard-plug-network
+ depends = switchboard-plug-notifications
+ depends = switchboard-plug-parental-controls
+ depends = switchboard-plug-power
+ depends = switchboard-plug-printers
+ depends = switchboard-plug-security-privacy
+ depends = switchboard-plug-sharing
+ depends = switchboard-plug-sound
+ depends = switchboard-plug-user-accounts
+ depends = otf-raleway
+ depends = ttf-dejavu
+ depends = ttf-droid
+ depends = ttf-liberation
+ depends = ttf-opensans
+ depends = wingpanel
+ depends = wingpanel-indicator-bluetooth
+ depends = wingpanel-indicator-datetime
+ depends = wingpanel-indicator-keyboard
+ depends = wingpanel-indicator-network
+ depends = wingpanel-indicator-notifications
+ depends = wingpanel-indicator-power
+ depends = wingpanel-indicator-session
+ depends = wingpanel-indicator-sound
+ depends = xorg-server
+ depends = xorg-xinit
+ optdepends = urutau-icons
+ optdepends = wingpanel-indicator-a11y
+ optdepends = wingpanel-indicator-nightlight
+ optdepends = wingpanel-indicator-privacy
+ provides = pantheon-stable
+ conflicts = pantheon-meta
+
+pkgname = pantheon-stable
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b25c15b81fae
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*~
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1984438fc3db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,93 @@
+# Maintainer: Helder Bertoldo <helder.bertoldo@gmail.com>
+# Contributor:
+
+pkgname=pantheon-stable
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Meta package for the complete Pantheon desktop & apps that uses stable versions"
+arch=(any)
+url="https://github.com/elementary"
+license=('GPL3')
+depends=(
+ 'cerbere'
+ 'contractor'
+ 'elementary-icon-theme'
+ 'elementary-wallpapers'
+ 'epiphany-pantheon'
+ 'file-roller'
+ 'gala'
+ 'geary'
+ 'gnome-settings-daemon-elementary'
+ 'granite'
+ 'gtk-theme-elementary'
+ 'lightdm'
+ 'lightdm-pantheon-greeter'
+ 'networkmanager'
+ 'pantheon-applications-menu'
+ 'pantheon-calculator'
+ 'pantheon-calendar'
+ 'pantheon-camera'
+ 'pantheon-code'
+ 'pantheon-default-settings'
+ 'pantheon-dpms-helper'
+ 'pantheon-files'
+ 'gvfs'
+ 'pantheon-geoclue2-agent'
+ 'pantheon-music'
+ 'pantheon-photos'
+ 'pantheon-polkit-agent'
+ 'pantheon-print'
+ 'pantheon-screenshot'
+ 'pantheon-session'
+ 'pantheon-shortcut-overlay'
+ 'pantheon-terminal'
+ 'pantheon-videos'
+ 'plank'
+ 'sound-theme-elementary-git'
+ 'switchboard'
+ 'switchboard-plug-a11y'
+ 'switchboard-plug-about'
+ 'switchboard-plug-bluetooth'
+ 'switchboard-plug-datetime'
+ 'switchboard-plug-desktop'
+ 'switchboard-plug-display'
+ 'switchboard-plug-elementary-tweaks'
+ 'switchboard-plug-applications'
+ 'switchboard-plug-keyboard'
+ 'switchboard-plug-locale'
+ 'switchboard-plug-mouse-touchpad'
+ 'switchboard-plug-network'
+ 'switchboard-plug-notifications'
+ 'switchboard-plug-parental-controls'
+ 'switchboard-plug-power'
+ 'switchboard-plug-printers'
+ 'switchboard-plug-security-privacy'
+ 'switchboard-plug-sharing'
+ 'switchboard-plug-sound'
+ 'switchboard-plug-user-accounts'
+ 'otf-raleway'
+ 'ttf-dejavu'
+ 'ttf-droid'
+ 'ttf-liberation'
+ 'ttf-opensans'
+ 'wingpanel'
+ 'wingpanel-indicator-bluetooth'
+ 'wingpanel-indicator-datetime'
+ 'wingpanel-indicator-keyboard'
+ 'wingpanel-indicator-network'
+ 'wingpanel-indicator-notifications'
+ 'wingpanel-indicator-power'
+ 'wingpanel-indicator-session'
+ 'wingpanel-indicator-sound'
+ 'xorg-server'
+ 'xorg-xinit'
+ )
+optdepends=('urutau-icons' 'wingpanel-indicator-a11y' 'wingpanel-indicator-nightlight' 'wingpanel-indicator-privacy')
+makedepends=('git' 'meson' 'ninja' 'vala>=0.40.3-1')
+provides=("${pkgname}")
+conflicts=('pantheon-meta')
+
+package(){
+ /bin/true
+}
+