summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2020-10-11 22:18:25 +0900
committerQue Quotion2020-10-11 22:18:25 +0900
commit1d9892fd299a65f2f33653e5ec4d7ddc0febecbe (patch)
tree04cc11c29c0e5bca9c2e16fb45352192ebbafc7f
parent8120b20731779f5656baaa5c3f8060847a45d4ea (diff)
downloadaur-1d9892fd299a65f2f33653e5ec4d7ddc0febecbe.tar.gz
Update csd autostarts: skip screensaver and xrandr; skip existing pantheon files
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0564ca079835..02ab23be9017 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pantheon-workarounds
pkgdesc = Workarounds for Pantheon derivatives
- pkgver = 3.2.0.r73.gc49189b
- pkgrel = 2
+ pkgver = 3.3.2.r96.g9dedf56
+ pkgrel = 1
url = https://github.com/quequotion/pantheon-qq
install = gala.install
arch = any
@@ -38,7 +38,7 @@ pkgbase = pantheon-workarounds
optdepends = pantheon-screenshot: The Pantheon Screenshot Tool
optdepends = pantheon-terminal: The Pantheon Terminal Emulator
optdepends = xscreensaver-dbus-screenlock: xscreensaver locker for gnome-derivative desktops
- optdepends = wingpanel-standalone-git: Stylish top panel that holds indicators and spawns an application launcher (with autohide and without Gala dependencies)
+ optdepends = wingpanel-standalone-git: Stylish top panel (with autohide and without Gala dependencies)
provides = libgala.so=0-64
conflicts = libgala.so=0-64
source = https://raw.githubusercontent.com/elementary/gala/master/data/org.pantheon.desktop.gala.gschema.xml.in
diff --git a/PKGBUILD b/PKGBUILD
index de3fc6faff99..ddf6797d213f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Ner0 <darkelfdarkelf666@yahoo.co.uk>
pkgname=pantheon-workarounds
-pkgver=3.2.0.r73.gc49189b
-pkgrel=2
+pkgver=3.3.2.r96.g9dedf56
+pkgrel=1
pkgdesc='Workarounds for Pantheon derivatives'
arch=('any')
url='https://github.com/quequotion/pantheon-qq'
@@ -34,12 +34,13 @@ optdepends=("contractor: A desktop-wide extension service"
"pantheon-screenshot: The Pantheon Screenshot Tool"
"pantheon-terminal: The Pantheon Terminal Emulator"
"xscreensaver-dbus-screenlock: xscreensaver locker for gnome-derivative desktops"
- "wingpanel-standalone-git: Stylish top panel that holds indicators and spawns an application launcher (with autohide and without Gala dependencies)")
+ "wingpanel-standalone-git: Stylish top panel (with autohide and without Gala dependencies)")
makedepends=('git' 'intltool')
provides=("libgala.so=0-64")
conflicts=("libgala.so=0-64")
install='gala.install'
-source=("https://raw.githubusercontent.com/elementary/gala/master/data/org.pantheon.desktop.gala.gschema.xml.in" 'pantheon-session-qq'
+source=("https://raw.githubusercontent.com/elementary/gala/master/data/org.pantheon.desktop.gala.gschema.xml.in"
+ 'pantheon-session-qq'
'numlockx-pantheon.desktop'
'gtk.css'
'settings.ini'
@@ -77,7 +78,11 @@ package() {
install -Dm755 {"${srcdir}","${pkgdir}"/usr/bin}/pantheon-session-qq
#Use cinnamon-settings-daemon (gnome-settings-daemon has deprecated modularity and xorg)
+ #Skip "Screensaver" plugin in Pantheon: session-indicator needs org.freedesktop.ScreenSaver.Lock
+ #Skip "Xrandr" plugin in Pantheon: monitors.xml configuration doesn't seem to work, is undocumented, etc
for i in /etc/xdg/autostart/cinnamon-settings-daemon-*.desktop; do
- sed s/X-Cinnamon/Pantheon/ "${i}" > "${pkgdir}${i/.desktop/-pantheon.desktop}"
+ if [[ ${i} != *screensaver* ]] && [[ ${i} != *xrandr* ]] && [[ ${i} != *pantheon* ]]; then
+ sed s/X-Cinnamon/Pantheon/ "${i}" > "${pkgdir}${i/.desktop/-pantheon.desktop}"
+ fi
done
}