summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArticExploit2023-02-18 11:24:53 +0100
committerArticExploit2023-02-18 11:24:53 +0100
commit16e2a2834f12d021aecb0f246a4fd3c988dbcb15 (patch)
treef817e0ba0b011cf29b7e8633b33e853dac3fd599
downloadaur-16e2a2834f12d021aecb0f246a4fd3c988dbcb15.tar.gz
Initial Commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD44
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b009b7ae27e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pantum-driver
+ pkgdesc = Linux driver for all M series and most P seriers Pantum printers V1.1.99
+ pkgver = 1.1.99
+ pkgrel = 1
+ arch = x86_64
+ arch = x86
+ arch = i686
+ arch = i386
+ arch = arm
+ arch = aarch64
+ license = proprietary
+ depends = sane
+ depends = cups
+ source = https://drivers.pantum.com/userfiles/files/download/%E9%A9%B1%E5%8A%A8%E6%96%87%E4%BB%B6/2013/Pantum%20Ubuntu%20Driver%20V1_1_99-1.zip
+ sha256sums = 64767c41223cb10f86fdbce37122580b00483233143fd703fe7d225f34df85c8
+
+pkgname = pantum-driver
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd069d5d6af0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# maintainer: ArticExploit <artic@articexploit.xyz>
+# contributor: Arch_user (in the artix forum, https://forum.artixlinux.org/index.php/topic,4601.msg29502.html#msg29502)
+pkgname=pantum-driver
+pkgver="1.1.99"
+pkgrel="1"
+pkgdesc="Linux driver for all M series and most P seriers Pantum printers V$pkgver"
+arch=('x86_64' 'x86' 'i686' 'i386' 'arm' "aarch64")
+license=('proprietary')
+depends=('sane' 'cups')
+source=(
+ "https://drivers.pantum.com/userfiles/files/download/%E9%A9%B1%E5%8A%A8%E6%96%87%E4%BB%B6/2013/Pantum%20Ubuntu%20Driver%20V1_1_99-1.zip"
+)
+
+sha256sums=(
+ "64767c41223cb10f86fdbce37122580b00483233143fd703fe7d225f34df85c8"
+)
+
+extract_deb()
+{
+ ar p $1 data.tar.xz | tar xJ
+}
+
+build()
+{
+ cd $srcdir/Pantum\ Ubuntu\ Driver\ V$pkgver-$pkgrel/Resources
+
+ mkdir -p pkg
+ cd ./pkg
+ extract_deb "../pantum_$pkgver-"$pkgrel"_amd64.deb"
+}
+
+package()
+{
+ # go into the package folder and copy the /usr into the root
+ cd ${pkgdir}
+ cp -r "${srcdir}/Pantum Ubuntu Driver V$pkgver-$pkgrel/Resources/pkg/"* .
+
+ # move this into that
+ # rm -r ./usr/lib64
+ cd usr/lib
+ #mv -u $arch-linux-gnu/* .
+ cp -a $arch-linux-gnu/* .
+ rm -r *-linux-gnu*
+}