summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorseniorivn2017-05-26 17:26:35 +0300
committerseniorivn2017-05-26 17:26:35 +0300
commitace719e64de5bffe967f724d403a993c76786896 (patch)
tree96c957c0ac9fb4c1e9d702ad263fb2389c5a986e
downloadaur-ace719e64de5bffe967f724d403a993c76786896.tar.gz
init version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD55
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..571d2dcb41cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pantum_driver
+ pkgdesc = Pantum M6200-M6500-M6550-M6600-MS6000 Series LINUX Driver V1.4.0
+ pkgver = 1.4.0
+ pkgrel = 0.1
+ arch = x86_64
+ arch = x86
+ arch = i686
+ arch = i386
+ license = proprietary
+ depends = sane
+ depends = cups
+ source = http://global.pantum.com/global/wp-content/uploads/2016/01/Pantum-M6200-M6500-M6550-M6600-MS6000-Series-LINUX-Driver-V1-4-0-tar.gz
+ md5sums = 9e9d93b83e8e78cd99f8db0a35cc422a
+
+pkgname = pantum_driver
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41d4e61e4f3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Binary variant maintainer: Swyter <swyterzone+aur@gmail.com>
+# Original package maintainer: Tomáš Mládek < tmladek {} inventati dt org >
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=pantum_driver
+pkgver="1.4.0"
+pkgrel="0.1"
+pkgdesc="Pantum M6200-M6500-M6550-M6600-MS6000 Series LINUX Driver V1.4.0"
+arch=('x86_64' 'x86' 'i686' 'i386')
+license=('proprietary')
+depends=('sane' 'cups')
+source=(
+ "http://global.pantum.com/global/wp-content/uploads/2016/01/Pantum-M6200-M6500-M6550-M6600-MS6000-Series-LINUX-Driver-V1-4-0-tar.gz"
+)
+
+md5sums=(
+ '9e9d93b83e8e78cd99f8db0a35cc422a'
+)
+
+#noextract=("aeskulap_0.2.2b1-11_amd64.deb" "libdcmtk2_3.6.0-12_amd64.deb" "libwrap0_7.6.q-25_amd64.deb")
+
+extract_deb()
+{
+ ar p $1 data.tar.gz | tar zx
+}
+
+build()
+{
+ # extract them all under the base /usr dir inside of the source folder
+ #extract_deb "aeskulap_0.2.2b1-11_amd64.deb"
+ #extract_deb "libdcmtk2_3.6.0-12_amd64.deb"
+ #extract_deb "libwrap0_7.6.q-25_amd64.deb"
+ cd ./ADF_LinuxInstaller/Resources
+
+ mkdir pkg
+ cd ./pkg
+ extract_deb "../Pantum-M6500-Series-3.0.$arch.deb"
+ extract_deb "../Pantum-M6500-Series-Sane-3.7.$arch.deb"
+
+
+}
+
+package()
+{
+ # go into the package folder and copy the /usr into the root
+ cd ${pkgdir}
+ cp -r ${srcdir}/ADF_LinuxInstaller/Resources/pkg/* .
+
+ # move this into that
+ cd usr/lib
+ #mv -u $arch-linux-gnu/* .
+ cp -a $arch-linux-gnu/* .
+ rm -r "$arch-linux-gnu"
+}
+